summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.8.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 16:14:57 +0000
commitbb2d6cc85d558b2292a1a76d42c7cb1ff9713332 (patch)
tree922414aa5f4ec9618c02657e69281f610380c7e3 /meta/recipes-support/lz4/lz4_1.8.3.bb
parent96e05ff4ce38fcb968ad4477f22fcc39c1860862 (diff)
downloadpoky-bb2d6cc85d558b2292a1a76d42c7cb1ff9713332.tar.gz
lz4: upgrade 1.8.2 -> 1.8.3
(From OE-Core rev: 9f67079b03239d7c46552070ad5c80d7d7f4c5bf) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.8.3.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.8.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.8.3.bb b/meta/recipes-support/lz4/lz4_1.8.3.bb
new file mode 100644
index 0000000000..125836f7bf
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.8.3.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3
4LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
5LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
6 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
8 "
9
10PE = "1"
11
12SRCREV = "641b453d9db536ee020851bfcb1dc39f61006f0a"
13
14SRC_URI = "git://github.com/lz4/lz4.git \
15 file://run-ptest \
16 "
17UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
22
23do_install() {
24 oe_runmake install
25}
26
27BBCLASSEXTEND = "native nativesdk"