summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.32.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-11-14 16:57:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-30 10:49:22 +0000
commit52656f7e38b515bdbc9d5dd4039f76312cf00c80 (patch)
treeb576b680708f6915535616116c22fd603215c027 /meta/recipes-support/libxslt/libxslt_1.1.32.bb
parent7d67ce0feb8c06d7d6c6d298efd4da3efe79500d (diff)
downloadpoky-52656f7e38b515bdbc9d5dd4039f76312cf00c80.tar.gz
libxslt: update to 1.1.32
(From OE-Core rev: b515861a16c25b6cc0350812343f08d7d1e384eb) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.32.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.32.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.32.bb b/meta/recipes-support/libxslt/libxslt_1.1.32.bb
new file mode 100644
index 0000000000..e8b1409d79
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.32.bb
@@ -0,0 +1,49 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
13 "
14
15SRC_URI[md5sum] = "1fc72f98e98bf4443f1651165f3aa146"
16SRC_URI[sha256sum] = "526ecd0abaf4a7789041622c3950c0e7f2c4c8835471515fd77eec684a355460"
17
18UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
19
20S = "${WORKDIR}/libxslt-${PV}"
21
22BINCONFIG = "${bindir}/xslt-config"
23
24inherit autotools pkgconfig binconfig-disabled lib_package
25
26# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
27do_configure_prepend () {
28 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
29
30 # The timestamps in the 1.1.28 tarball are messed up causing this file to
31 # appear out of date. Touch it so that we don't try to regenerate it.
32 touch ${S}/doc/xsltproc.1
33}
34
35EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
36# older versions of this recipe had ${PN}-utils
37RPROVIDES_${PN}-bin += "${PN}-utils"
38RCONFLICTS_${PN}-bin += "${PN}-utils"
39RREPLACES_${PN}-bin += "${PN}-utils"
40
41
42do_install_append_class-native () {
43 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
44}
45
46FILES_${PN} += "${libdir}/libxslt-plugins"
47FILES_${PN}-dev += "${libdir}/xsltConf.sh"
48
49BBCLASSEXTEND = "native nativesdk"