summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.28.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-12-03 17:27:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:31:10 +0000
commitbce1cce5990cd064e6eaec859ff5e999bdf0959c (patch)
treef6ef023a7cb9a497a32addb7b04c79e9b7fe890f /meta/recipes-support/libxslt/libxslt_1.1.28.bb
parent53890fb8ce8bac6e5fa14ce1ad0ca68a17f46da3 (diff)
downloadpoky-bce1cce5990cd064e6eaec859ff5e999bdf0959c.tar.gz
libxslt: upgrade to 1.1.28
(From OE-Core rev: b3f32cd46d8ee8a17037365b9c2ab19bbf542c72) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.28.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
new file mode 100644
index 0000000000..3f89e78df6
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10PR = "r0"
11
12SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
13 file://pkgconfig_fix.patch"
14
15SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
16SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
17S = "${WORKDIR}/libxslt-${PV}"
18
19inherit autotools pkgconfig binconfig lib_package
20
21# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
22do_configure_prepend () {
23 sed -i -e 's/ansidecl.h//' ${S}/configure.in
24}
25
26EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
27# older versions of this recipe had ${PN}-utils
28RPROVIDES_${PN}-bin += "${PN}-utils"
29RCONFLICTS_${PN}-bin += "${PN}-utils"
30RREPLACES_${PN}-bin += "${PN}-utils"
31
32FILES_${PN} += "${libdir}/libxslt-plugins"
33FILES_${PN}-dev += "${libdir}/xsltConf.sh"
34
35BBCLASSEXTEND = "native"