summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.27.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-11-09 12:00:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-12 13:36:39 +0000
commit210839e7a53092f3847def82cfa4a1b11723e4eb (patch)
treecc1cc365b474b48e0787302d87e4a079a21ed188 /meta/recipes-support/libxslt/libxslt_1.1.27.bb
parentd69683f2303a6759ee28730027e51d0aff9430e2 (diff)
downloadpoky-210839e7a53092f3847def82cfa4a1b11723e4eb.tar.gz
libxslt: upgrade to 1.1.27
pkgconfig_fix.patch: adapted to the new version (From OE-Core rev: 960ad0998a9edbefe57d08b6f587682f0dc9d768) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.27.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.27.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.27.bb b/meta/recipes-support/libxslt/libxslt_1.1.27.bb
new file mode 100644
index 0000000000..925c8608c5
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.27.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10PR = "r0"
11
12SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
13 file://pkgconfig_fix.patch"
14
15SRC_URI[md5sum] = "4d01ff464b9ea7236925a1adf147c7f8"
16SRC_URI[sha256sum] = "b6a8d9a421f2630999ca91d9f8c091ee8ea2d580e6be84c1d21b2a45e11e7e26"
17S = "${WORKDIR}/libxslt-${PV}"
18
19inherit autotools pkgconfig binconfig lib_package
20
21# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
22do_configure_prepend () {
23 sed -i -e 's/ansidecl.h//' ${S}/configure.in
24}
25
26EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
27# older versions of this recipe had ${PN}-utils
28RPROVIDES_${PN}-bin += "${PN}-utils"
29RCONFLICTS_${PN}-bin += "${PN}-utils"
30RREPLACES_${PN}-bin += "${PN}-utils"
31
32FILES_${PN} += "${libdir}/libxslt-plugins"
33FILES_${PN}-dev += "${libdir}/xsltConf.sh"
34
35BBCLASSEXTEND = "native"