summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup_3.2.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-14 11:20:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-15 09:38:37 +0000
commit2845c06fff103d73d92bc1eb5884fc7d14195b07 (patch)
tree9e5f0b0895c32fdac7cf376b91f023d6894a2424 /meta/recipes-support/libsoup/libsoup_3.2.2.bb
parent8531a791933d854fc9feaf02da3fdb66ee262d03 (diff)
downloadpoky-2845c06fff103d73d92bc1eb5884fc7d14195b07.tar.gz
libsoup: upgrade 3.2.1 -> 3.2.2
Changelog: ========== * Various HTTP/2 Fixes: * Fix `content-sniffed` not being emitted for resources without content * Fix leak of SoupServerConnection when stolen (From OE-Core rev: 65d287feb713a21cefdf4cb56f80c9f1deaa2e60) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup_3.2.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup_3.2.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup_3.2.2.bb b/meta/recipes-support/libsoup/libsoup_3.2.2.bb
new file mode 100644
index 0000000000..e16cd17705
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup_3.2.2.bb
@@ -0,0 +1,46 @@
1SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
7LICENSE = "LGPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
15SRC_URI[sha256sum] = "83673c685b910fb7d39f1f28eee5afbefb71c05798fc350ac3bf1b885e1efaa1"
16
17PROVIDES = "libsoup-3.0"
18CVE_PRODUCT = "libsoup"
19
20S = "${WORKDIR}/libsoup-${PV}"
21
22inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gi-docgen
23
24GIR_MESON_ENABLE_FLAG = 'enabled'
25GIR_MESON_DISABLE_FLAG = 'disabled'
26
27# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
30
31EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
32
33GIDOCGEN_MESON_OPTION = 'docs'
34GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
35GIDOCGEN_MESON_DISABLE_FLAG = 'disabled'
36
37# When built without gnome support, libsoup will contain only one shared lib
38# and will therefore become subject to renaming by debian.bbclass. Prevent
39# renaming in order to keep the package name consistent regardless of whether
40# gnome support is enabled or disabled.
41DEBIAN_NOAUTONAME:${PN} = "1"
42
43# glib-networking is needed for SSL, proxies, etc.
44RRECOMMENDS:${PN} = "glib-networking"
45
46BBCLASSEXTEND = "native nativesdk"