summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-11-29 22:59:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-01 16:23:45 +0000
commit72c76db9d7845fea91ac3e34739beb2924ffa446 (patch)
tree469acd431a0c0c75eff9e2b381cd9d30f8664d75 /meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb
parent22fd9de07f17b08e92d1ac0169ad95601a3ee2bb (diff)
downloadpoky-72c76db9d7845fea91ac3e34739beb2924ffa446.tar.gz
libsoup-2.4: upgrade 2.74.1 -> 2.74.2
Changes in libsoup from 2.74.1 to 2.74.2: * Error when libsoup3 is already loaded before libsoup2 (From OE-Core rev: 0640eb72ef4db97fc07011d8398dbafbd3c8b119) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb
new file mode 100644
index 0000000000..9b3a57dab0
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.74.2.bb
@@ -0,0 +1,46 @@
1SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
7LICENSE = "LGPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
15SRC_URI[sha256sum] = "f0a427656e5fe19e1df71c107e88dfa1b2e673c25c547b7823b6018b40d01159"
16
17CVE_PRODUCT = "libsoup"
18
19S = "${WORKDIR}/libsoup-${PV}"
20
21inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23UPSTREAM_CHECK_REGEX = "libsoup-(?P<pver>2(\.(?!99)\d+)+)\.tar"
24
25GIR_MESON_ENABLE_FLAG = 'enabled'
26GIR_MESON_DISABLE_FLAG = 'disabled'
27
28# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
29PACKAGECONFIG ??= ""
30PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
31PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
32
33EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
34
35GTKDOC_MESON_OPTION = "gtk_doc"
36
37# When built without gnome support, libsoup-2.4 will contain only one shared lib
38# and will therefore become subject to renaming by debian.bbclass. Prevent
39# renaming in order to keep the package name consistent regardless of whether
40# gnome support is enabled or disabled.
41DEBIAN_NOAUTONAME:${PN} = "1"
42
43# glib-networking is needed for SSL, proxies, etc.
44RRECOMMENDS:${PN} = "glib-networking"
45
46BBCLASSEXTEND = "native nativesdk"