summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-11-10 15:46:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-30 10:49:20 +0000
commitdbe4694c5e85e36edd58f47a9eb16191b6430354 (patch)
tree91df1696aee627548e3a55d13a59a4ee32001f54 /meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb
parenta67c4f3f6f7df4080f665904fc9ab1e000041992 (diff)
downloadpoky-dbe4694c5e85e36edd58f47a9eb16191b6430354.tar.gz
libsoup-2.4: upgrade to 2.60.2
2.60.1 -> 2.60.2 (From OE-Core rev: c008fb8270209e790cc71b6a7ec776aef0a57c49) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb
new file mode 100644
index 0000000000..abc7bdbc6d
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.60.2.bb
@@ -0,0 +1,35 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
13
14SRC_URI[md5sum] = "9c49831b62c4bf18cdb81c86ac6516fd"
15SRC_URI[sha256sum] = "7263cfe18872e2e652c196f5667e514616d9c97c861dfca82a65a55f45f0da01"
16
17S = "${WORKDIR}/libsoup-${PV}"
18
19inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
20
21# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
24PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
25
26EXTRA_OECONF = "--disable-vala"
27
28# When built without gnome support, libsoup-2.4 will contain only one shared lib
29# and will therefore become subject to renaming by debian.bbclass. Prevent
30# renaming in order to keep the package name consistent regardless of whether
31# gnome support is enabled or disabled.
32DEBIAN_NOAUTONAME_${PN} = "1"
33
34# glib-networking is needed for SSL, proxies, etc.
35RRECOMMENDS_${PN} = "glib-networking"