summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.44.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-02-25 19:53:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-28 23:11:28 +0000
commit95dfc6f150164f59bd6c9b48d03d6751ce5975c1 (patch)
treeb8d9e981f5e66344a28d11c7a362877c55ae94bb /meta/recipes-support/libpcre/libpcre_8.44.bb
parent9d716ccf476c7d2c11e180d5ef85ae8209fb2f49 (diff)
downloadpoky-95dfc6f150164f59bd6c9b48d03d6751ce5975c1.tar.gz
libpcre: upgrade 8.43 -> 8.44
License-Update: copyright years (From OE-Core rev: 09f6639ed599f71a4ec58305b9d684ccc8983ba0) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.44.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.44.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.44.bb b/meta/recipes-support/libpcre/libpcre_8.44.bb
new file mode 100644
index 0000000000..e5471e81da
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.44.bb
@@ -0,0 +1,75 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=3bb381a66a5385b246d4877922e7511e"
10SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre-${PV}.tar.bz2 \
11 file://fix-pcre-name-collision.patch \
12 file://run-ptest \
13 file://Makefile \
14 "
15
16SRC_URI[md5sum] = "cf7326204cc46c755b5b2608033d9d24"
17SRC_URI[sha256sum] = "19108658b23b3ec5058edc9f66ac545ea19f9537234be1ec62b714c84399366d"
18
19CVE_PRODUCT = "pcre"
20
21S = "${WORKDIR}/pcre-${PV}"
22
23PROVIDES += "pcre"
24DEPENDS += "bzip2 zlib"
25
26PACKAGECONFIG ??= "pcre8 unicode-properties jit"
27
28PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
29PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
30PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
31PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
32PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties"
33PACKAGECONFIG[jit] = "--enable-jit=auto,--disable-jit"
34
35BINCONFIG = "${bindir}/pcre-config"
36
37inherit autotools binconfig-disabled ptest
38
39EXTRA_OECONF = "--enable-utf"
40
41PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
42
43SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
44SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
45SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
46SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
47SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
48SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
49
50FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
51FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
52FILES_pcregrep = "${bindir}/pcregrep"
53FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
54FILES_pcretest = "${bindir}/pcretest"
55FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
56
57BBCLASSEXTEND = "native nativesdk"
58
59do_install_ptest() {
60 t=${D}${PTEST_PATH}
61 cp ${WORKDIR}/Makefile $t
62 cp -r ${S}/testdata $t
63 for i in pcre_stringpiece_unittest pcregrep pcretest; \
64 do cp ${B}/.libs/$i $t; \
65 done
66 for i in RunTest RunGrepTest test-driver; \
67 do cp ${S}/$i $t; \
68 done
69 # Skip the fr_FR locale test. If the locale fr_FR is found, it is tested.
70 # If not found, the test is skipped. The test program assumes fr_FR is non-UTF-8
71 # locale so the test fails if fr_FR is UTF-8 locale.
72 sed -i -e 's:do3=yes:do3=no:g' ${D}${PTEST_PATH}/RunTest
73}
74
75RDEPENDS_${PN}-ptest += "make"