summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.38.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-01-27 14:20:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 12:13:10 +0000
commit049be17b533d7c592dae8e0f33ddbae54639a776 (patch)
tree6dd8ef53b2d0212d6b200fcb561b8442cfe3c1c2 /meta/recipes-support/libpcre/libpcre_8.38.bb
parent5e94ac7ba9350aa5ac87955aa216150a0338ff22 (diff)
downloadpoky-049be17b533d7c592dae8e0f33ddbae54639a776.tar.gz
libpcre: bug fixes include security
[Yocto # 9008] This is the next patch release for pcre. The 8.xx series now only contains bug fixes. http://www.pcre.org/original/changelog.txt The following security fixes are included: CVE-2015-3210 pcre: heap buffer overflow in pcre_compile2() / compile_regex() CVE-2015-3217 pcre: stack overflow in match() CVE-2015-5073 CVE-2015-8388 pcre: Buffer overflow caused by certain patterns with an unmatched closing parenthesis CVE-2015-8380 pcre: Heap-based buffer overflow in pcre_exec CVE-2015-8381 pcre: Heap Overflow in compile_regex() CVE-2015-8383 pcre: Buffer overflow caused by repeated conditional group CVE-2015-8384 pcre: Buffer overflow caused by recursive back reference by name within certain group CVE-2015-8385 pcre: Buffer overflow caused by forward reference by name to certain group CVE-2015-8386 pcre: Buffer overflow caused by lookbehind assertion CVE-2015-8387 pcre: Integer overflow in subroutine calls CVE-2015-8389 pcre: Infinite recursion in JIT compiler when processing certain patterns CVE-2015-8390 pcre: Reading from uninitialized memory when processing certain patterns CVE-2015-8392 pcre: Buffer overflow caused by certain patterns with duplicated named groups CVE-2015-8393 pcre: Information leak when running pcgrep -q on crafted binary CVE-2015-8394 pcre: Integer overflow caused by missing check for certain conditions CVE-2015-8395 pcre: Buffer overflow caused by certain references CVE-2016-1283 pcre: Heap buffer overflow in pcre_compile2 causes DoS (From OE-Core rev: 3e403cc1bdeefd4f39e54bae2269ca56307e8468) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.38.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.38.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.38.bb b/meta/recipes-support/libpcre/libpcre_8.38.bb
new file mode 100644
index 0000000000..c5676073e8
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.38.bb
@@ -0,0 +1,78 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "00aabbfe56d5a48b270f999b508c5ad2"
18SRC_URI[sha256sum] = "b9e02d36e23024d6c02a2e5b25204b3a4fa6ade43e0a5f869f254f49535079df"
19
20S = "${WORKDIR}/pcre-${PV}"
21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib"
24
25PACKAGECONFIG ??= "pcre8"
26
27PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
28PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
29PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
30PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
31
32BINCONFIG = "${bindir}/pcre-config"
33
34inherit autotools binconfig-disabled ptest
35
36EXTRA_OECONF = "\
37 --enable-newline-is-lf \
38 --enable-rebuild-chartables \
39 --enable-utf8 \
40 --with-link-size=2 \
41 --with-match-limit=10000000 \
42"
43
44# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
45# set CFLAGS_FOR_BUILD, required for the libpcre build.
46BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
47CFLAGS += "-D_REENTRANT"
48CXXFLAGS_append_powerpc = " -lstdc++"
49
50PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
51
52SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
53SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
54SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
55SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
56SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
57SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
58
59FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
60FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
61FILES_pcregrep = "${bindir}/pcregrep"
62FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
63FILES_pcretest = "${bindir}/pcretest"
64FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
65
66BBCLASSEXTEND = "native nativesdk"
67
68do_install_ptest() {
69 t=${D}${PTEST_PATH}
70 cp ${WORKDIR}/Makefile $t
71 cp -r ${S}/testdata $t
72 for i in pcre_stringpiece_unittest pcregrep pcretest; \
73 do cp ${B}/.libs/$i $t; \
74 done
75 for i in RunTest RunGrepTest test-driver; \
76 do cp ${S}/$i $t; \
77 done
78}