summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.34.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-05-19 13:36:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-21 09:09:01 +0100
commit0a23586271e92784ef184ac852a7a2a24df6b787 (patch)
tree3126b53e9d10b883b5ec54929e8193b819998a7a /meta/recipes-support/libpcre/libpcre_8.34.bb
parent00846f62a7ba95a95303e276774ca0d6396b8f60 (diff)
downloadpoky-0a23586271e92784ef184ac852a7a2a24df6b787.tar.gz
libpcre: Update to 8.35 version
Upgrade libpcre to 8.35 version. (From OE-Core rev: 32c007bfc4fe7a0ba75644584bb80f8bdff09a01) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.34.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.34.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.34.bb b/meta/recipes-support/libpcre/libpcre_8.34.bb
deleted file mode 100644
index 5c5072cb90..0000000000
--- a/meta/recipes-support/libpcre/libpcre_8.34.bb
+++ /dev/null
@@ -1,73 +0,0 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "5439e321351bddd5533551bbce128d07"
18SRC_URI[sha256sum] = "b6043ae1ff2720be665ffa28dc22b7c637cdde96f389a116c0c3020caeae583f"
19
20S = "${WORKDIR}/pcre-${PV}"
21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib"
24
25PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
26
27inherit autotools binconfig ptest
28
29PARALLEL_MAKE = ""
30
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --enable-rebuild-chartables \
34 --enable-utf8 \
35 --with-link-size=2 \
36 --with-match-limit=10000000 \
37"
38
39# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
40# set CFLAGS_FOR_BUILD, required for the libpcre build.
41BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
42CFLAGS += "-D_REENTRANT"
43CXXFLAGS_append_powerpc = " -lstdc++"
44
45PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
46
47SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
48SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
49SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
50SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
51SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
52SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
53
54FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
55FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
56FILES_pcregrep = "${bindir}/pcregrep"
57FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
58FILES_pcretest = "${bindir}/pcretest"
59FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
60
61BBCLASSEXTEND = "native nativesdk"
62
63do_install_ptest() {
64 t=${D}${PTEST_PATH}
65 cp ${WORKDIR}/Makefile $t
66 cp -r ${S}/testdata $t
67 for i in pcre_stringpiece_unittest pcregrep pcretest; \
68 do cp ${B}/.libs/$i $t; \
69 done
70 for i in RunTest RunGrepTest test-driver; \
71 do cp ${S}/$i $t; \
72 done
73}