summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.32.bb
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2012-12-10 19:51:21 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-13 15:18:43 +0000
commit9820786bbaf51fca38cf6ec90de623b8420500e1 (patch)
treef507b5c923a231946a9bc34d576e239c67b83d90 /meta/recipes-support/libpcre/libpcre_8.32.bb
parentf615f0c140aa0748a16bb34ad5c19d828bd57ea2 (diff)
downloadpoky-9820786bbaf51fca38cf6ec90de623b8420500e1.tar.gz
libpcre: Improve the recipe
- Improve the cross patch to determine *_FOR_BUILD in configure - Leverage the fact that autotools.bbclass handles *_FOR_BUILD now - Drop the now unnecessary do_compile override - Drop the do_split_packages - Split out packages for pcregrep, pcretest, in addition to libpcrecpp and libpcreposix - add nativesdk to BBCLASSEXTEND as well as native (From OE-Core rev: 9867a9ad7a80a26654326650752dbbe89c8de3c5) Signed-off-by: Christopher Larson <chris_larson@mentor.com> - the patch was imported from meta-mentor layer on yoctoproject git server http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id 62f819b97e356c1d7468fbccbf3a3ceed78b09a8 - broken up the original patch in two parts, this part contains some improvements to the recipe and the cross patch Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.32.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.32.bb65
1 files changed, 35 insertions, 30 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.32.bb b/meta/recipes-support/libpcre/libpcre_8.32.bb
index b6847e8217..e434d55ce9 100644
--- a/meta/recipes-support/libpcre/libpcre_8.32.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.32.bb
@@ -5,7 +5,7 @@ to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions" 5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org" 6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel" 7SECTION = "devel"
8PR = "r0" 8PR = "r1"
9LICENSE = "BSD" 9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=115e2bee152e2e23e838a29136094877" 10LIC_FILES_CHKSUM = "file://LICENCE;md5=115e2bee152e2e23e838a29136094877"
11SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \ 11SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
@@ -17,37 +17,42 @@ SRC_URI[sha256sum] = "a913fb9bd058ef380a2d91847c3c23fcf98e92dc3b47cd08a53c021c5c
17 17
18S = "${WORKDIR}/pcre-${PV}" 18S = "${WORKDIR}/pcre-${PV}"
19 19
20PROVIDES = "pcre" 20FILESPATH .= ":${@base_set_filespath([bb.which(BBPATH, 'recipes-support/libpcre/files', direction=True)], d)}"
21DEPENDS = "bzip2 zlib readline" 21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib readline"
22 24
23inherit autotools binconfig 25inherit autotools binconfig
24 26
25PARALLEL_MAKE = "" 27PARALLEL_MAKE = ""
26 28
27CFLAGS_append = " -D_REENTRANT" 29EXTRA_OECONF = "\
28CXXFLAGS_powerpc += "-lstdc++" 30 --enable-newline-is-lf \
29EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8" 31 --enable-rebuild-chartables \
30 32 --enable-utf8 \
31do_compile () { 33 --with-link-size=2 \
32 # stop libtool from trying to link with host libraries - fix from #33 34 --with-match-limit=10000000 \
33 # this resolve build problem on amd64 - #1015 35"
34 if [ -e ${S}/${HOST_SYS}-libtool ] ; then 36
35 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool 37BUILD_CPPFLAGS += "-DLINK_SIZE=2"
36 else 38BUILD_CFLAGS =+ "-I${S}/include"
37 ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool 39CFLAGS += "-D_REENTRANT"
38 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool 40CXXFLAGS_append_powerpc = " -lstdc++"
39 fi 41
40 42PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
41 # The generation of dftables can lead to timestamp problems with ccache 43
42 # because the generated config.h seems newer. It is sufficient to ensure that the 44SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
43 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is 45SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
44 # only used for this). 46SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
45 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib" 47SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
46} 48SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
47 49SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
48python populate_packages_prepend () { 50
49 pcre_libdir = d.expand('${libdir}') 51FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
50 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True, prepend=True) 52FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
51} 53FILES_pcregrep = "${bindir}/pcregrep"
52 54FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
53BBCLASSEXTEND = "native" 55FILES_pcretest = "${bindir}/pcretest"
56FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
57
58BBCLASSEXTEND = "native nativesdk"