summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.21.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-01-10 18:04:39 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:53:15 +0000
commitccd2a31003315b9627b7a58331de422ce6bc173e (patch)
tree0daf7e4ec769924f8241a304996fee98a724d4a4 /meta/recipes-support/libpcre/libpcre_8.21.bb
parent8f44e9030b9671bd5083ddc2f412ee455f8aacc7 (diff)
downloadpoky-ccd2a31003315b9627b7a58331de422ce6bc173e.tar.gz
libpcre: upgrade from 8.20 to 8.21
(From OE-Core rev: efd200bc0db4d290445f742798e20914e4db347a) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.21.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.21.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.21.bb b/meta/recipes-support/libpcre/libpcre_8.21.bb
new file mode 100644
index 0000000000..4eb65d7e32
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.21.bb
@@ -0,0 +1,56 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r0"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=2f00d186a775c8002422a5315079d96b"
11SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
12 file://pcre-cross.patch \
13 file://fix-pcre-name-collision.patch"
14
15SRC_URI[md5sum] = "0a7b592bea64b7aa7f4011fc7171a730"
16SRC_URI[sha256sum] = "a4b8509d11fc2764fb4e1415b764ad2c214459edc011ce48aeeb6bbe1ac599e3"
17
18S = "${WORKDIR}/pcre-${PV}"
19
20PROVIDES = "pcre"
21DEPENDS = "bzip2 zlib readline"
22
23inherit autotools binconfig
24
25PARALLEL_MAKE = ""
26
27CFLAGS_append = " -D_REENTRANT"
28CXXFLAGS_powerpc += "-lstdc++"
29EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
30
31do_compile () {
32 # stop libtool from trying to link with host libraries - fix from #33
33 # this resolve build problem on amd64 - #1015
34 if [ -e ${S}/${HOST_SYS}-libtool ] ; then
35 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
36 else
37 ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool
38 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
39 fi
40
41 # The generation of dftables can lead to timestamp problems with ccache
42 # because the generated config.h seems newer. It is sufficient to ensure that the
43 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
44 # only used for this).
45 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
46}
47
48python populate_packages_prepend () {
49 pcre_libdir = bb.data.expand('${libdir}', d)
50 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
51}
52
53FILES_${PN} = "${libdir}/libpcre.so.*"
54FILES_${PN}-dev += "${bindir}/*"
55
56BBCLASSEXTEND = "native"