summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre2_10.30.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-11-03 12:54:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-07 13:25:31 +0000
commite14152226339a76d5192ff9a49d07ed044b071c4 (patch)
treef769565f62f3f6a08873a09d47af7bb10f1b4355 /meta/recipes-support/libpcre/libpcre2_10.30.bb
parent2e2ba4597e80b451e98d8197a66ef9011a4701c1 (diff)
downloadpoky-e14152226339a76d5192ff9a49d07ed044b071c4.tar.gz
libpcre2: update to 10.30
LICENSE files changed: Amend licence to relax its conditions for chains of binary distributions. removed included patches includes CVE-2017-8399 (From OE-Core rev: d8ea0674d1feee803b75cf837e8d029619f8d663) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre2_10.30.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre2_10.30.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre2_10.30.bb b/meta/recipes-support/libpcre/libpcre2_10.30.bb
new file mode 100644
index 0000000000..a7df055906
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre2_10.30.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=12d55e15a0c6da5c645ba40382bd3293"
12
13SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2 \
14 file://pcre-cross.patch \
15"
16
17SRC_URI[md5sum] = "d3adf4b130eed854a530390f00020a65"
18SRC_URI[sha256sum] = "90bd41c605d30e3745771eb81928d779f158081a51b2f314bbcc1f73de5773db"
19
20CVE_PRODUCT = "pcre2"
21
22S = "${WORKDIR}/pcre2-${PV}"
23
24PROVIDES += "pcre2"
25DEPENDS += "bzip2 zlib"
26
27BINCONFIG = "${bindir}/pcre2-config"
28
29inherit autotools binconfig-disabled
30
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --enable-rebuild-chartables \
34 --with-link-size=2 \
35 --with-match-limit=10000000 \
36"
37
38# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
39# set CFLAGS_FOR_BUILD, required for the libpcre build.
40BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}/src"
41CFLAGS += "-D_REENTRANT"
42CXXFLAGS_append_powerpc = " -lstdc++"
43
44export CCLD_FOR_BUILD ="${BUILD_CCLD}"
45
46PACKAGES =+ "pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
47
48SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
49SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
50SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
51SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
52
53FILES_pcre2grep = "${bindir}/pcre2grep"
54FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
55FILES_pcre2test = "${bindir}/pcre2test"
56FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
57
58BBCLASSEXTEND = "native nativesdk"