summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-04-19 11:00:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-20 13:56:48 +0100
commit76a9b01ff3553dcae4da616952f91fb3b667e0ab (patch)
treec412957088906866630ac367340df12d7baf84b7 /meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb
parent5aa20fe1b999b39f6619f5bf5beff6d1d2d3d6e7 (diff)
downloadpoky-76a9b01ff3553dcae4da616952f91fb3b667e0ab.tar.gz
libmicrohttpd: add a recipe from meta-oe
This is required to enable debuginfod in elfutils. (From OE-Core rev: e6035099772a0ccbb4835c0c782317c19527876c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb')
-rw-r--r--meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb
new file mode 100644
index 0000000000..66c48da3b7
--- /dev/null
+++ b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.72.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
10SRC_URI[md5sum] = "2a286193af88ab2ae3149748d4b46187"
11SRC_URI[sha256sum] = "0ae825f8e0d7f41201fd44a0df1cf454c1cb0bc50fe9d59c26552260264c2ff8"
12
13inherit autotools lib_package pkgconfig gettext
14
15CFLAGS += "-pthread -D_REENTRANT"
16
17EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
18
19PACKAGECONFIG ?= "curl https"
20PACKAGECONFIG_append_class-target = "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
22"
23PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
24PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
25PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
26
27do_compile_append() {
28 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
29}
30
31BBCLASSEXTEND = "native nativesdk"