summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.7.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-12-19 12:44:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:42 +0000
commitc729857c441cddf7f8214763ca766a5a8e842712 (patch)
treec5163cdd9cac65cf98646d7cefa8d53f6ce2ae07 /meta/recipes-support/libical/libical_3.0.7.bb
parent5e0b62675a6373828713b757b3a35d1fb20da264 (diff)
downloadpoky-c729857c441cddf7f8214763ca766a5a8e842712.tar.gz
libical: upgrade 3.0.6 -> 3.0.7
License-Update: URL updated. (From OE-Core rev: 49ad92a577f785b1e95385adc26374544d931c5a) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.7.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.7.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.7.bb b/meta/recipes-support/libical/libical_3.0.7.bb
new file mode 100644
index 0000000000..ac9c114691
--- /dev/null
+++ b/meta/recipes-support/libical/libical_3.0.7.bb
@@ -0,0 +1,44 @@
1SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2HOMEPAGE = "https://github.com/libical/libical"
3BUGTRACKER = "https://github.com/libical/libical/issues"
4LICENSE = "LGPLv2.1 | MPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
6 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
7 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
8 "
9SECTION = "libs"
10
11SRC_URI = " \
12 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
13 file://0001-Use-our-hand-build-native-src-generator.patch \
14"
15SRC_URI[md5sum] = "8a5d07a7fba9e73a85e67f76258bf042"
16SRC_URI[sha256sum] = "0abe66df1ea826e57db7f281c704ede834c84139012e6c686ea7adafd4e763fc"
17UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
18
19inherit cmake pkgconfig
20
21do_compile_prepend() {
22 # As long as https://github.com/libical/libical/issues/394 is open build native src-generator manually
23 NATIVE_CFLAGS="${BUILD_CFLAGS} `pkg-config-native --cflags glib-2.0` `pkg-config-native --cflags libxml-2.0`"
24 NATIVE_LDFLAGS="${BUILD_LDFLAGS} `pkg-config-native --libs glib-2.0` `pkg-config-native --libs libxml-2.0`"
25 ${BUILD_CC} $NATIVE_CFLAGS ${S}/src/libical-glib/tools/generator.c ${S}/src/libical-glib/tools/xml-parser.c -o ${B}/src-generator $NATIVE_LDFLAGS
26}
27
28PACKAGECONFIG ??= "icu glib"
29PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
30PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
31# ICU is used for RSCALE (RFC7529) support
32PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
33
34# No need to use perl-native, the host perl is sufficient.
35EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
36# doc build fails with linker error (??) for libical-glib so disable it
37EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
38
39do_install_append () {
40 # Remove build host references
41 sed -i \
42 -e 's,${STAGING_LIBDIR},${libdir},g' \
43 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake
44}