summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.38.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:36:00 +0100
commit1262d0591e4142e60bdda33c0b6449381aa522c7 (patch)
tree7121e26575cfa7bea1e6f8ad3d252ffa5b0e5ca2 /meta/recipes-support/libgpg-error/libgpg-error_1.38.bb
parent65784edd0f7b7ef2a260a3229329bffdc1da3092 (diff)
downloadpoky-1262d0591e4142e60bdda33c0b6449381aa522c7.tar.gz
libgpg-error: update 1.37 -> 1.38
Drop the do_compile_prepend logic as upstream now handles it correctly. License-Update: copyright years (From OE-Core rev: 830a955ab2f3c22ed44918a88adb79ba719eedbc) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.38.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.38.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.38.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.38.bb
new file mode 100644
index 0000000000..9a3ec9b5bd
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.38.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
9 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
10 "
11
12
13SECTION = "libs"
14
15UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
16SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
17 file://pkgconfig.patch \
18 file://0001-Do-not-fail-when-testing-config-scripts.patch \
19 file://0003-build-Fix-cross-compiling-into-a-separate-build-dir.patch \
20 file://0005-src-gen-lock-obj.sh-add-a-file.patch \
21 "
22
23SRC_URI[sha256sum] = "d8988275aa69d7149f931c10442e9e34c0242674249e171592b430ff7b3afd02"
24
25BINCONFIG = "${bindir}/gpg-error-config"
26
27inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
28
29MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
30
31CPPFLAGS += "-P"
32
33do_install_append() {
34 # we don't have common lisp in OE
35 rm -rf "${D}${datadir}/common-lisp/"
36 oe_multilib_header gpg-error.h gpgrt.h
37}
38
39FILES_${PN}-dev += "${bindir}/gpg-error"
40FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
41
42BBCLASSEXTEND = "native nativesdk"