summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.32.bb
diff options
context:
space:
mode:
authorAlexey Brodkin <alexey.brodkin@synopsys.com>2018-10-17 11:56:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-18 10:56:55 +0100
commite95caf1ebdfa29c9e1bc9c28ad0c47672c49fe99 (patch)
tree4c33da88d34e6f2bdac4124c9a41578f07340cd0 /meta/recipes-support/libgpg-error/libgpg-error_1.32.bb
parentff74cc841a9eae31e435564db2d7acefb5d4340e (diff)
downloadpoky-e95caf1ebdfa29c9e1bc9c28ad0c47672c49fe99.tar.gz
libgpg-error: Add ARC support
(From OE-Core rev: 2d9dbcc638cc39b935b89b6e66ed216ea9b05d62) Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.32.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.32.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.32.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.32.bb
index a4c720be9d..4f3e3d86cc 100644
--- a/meta/recipes-support/libgpg-error/libgpg-error_1.32.bb
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.32.bb
@@ -14,6 +14,8 @@ SECTION = "libs"
14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" 14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \ 15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
16 file://pkgconfig.patch \ 16 file://pkgconfig.patch \
17 file://0001-syscfg-Support-ARC-CPUs-and-simplify-aliasing-table.patch \
18 file://0002-syscfg-Add-support-for-arc-unknown-linux-gnu.patch \
17 " 19 "
18SRC_URI[md5sum] = "ef3d928a5a453fa701ecc3bb22be1c64" 20SRC_URI[md5sum] = "ef3d928a5a453fa701ecc3bb22be1c64"
19SRC_URI[sha256sum] = "c345c5e73cc2332f8d50db84a2280abfb1d8f6d4f1858b9daa30404db44540ca" 21SRC_URI[sha256sum] = "c345c5e73cc2332f8d50db84a2280abfb1d8f6d4f1858b9daa30404db44540ca"
@@ -30,6 +32,9 @@ do_compile_prepend() {
30 if [ ${TARGET_OS} = "mingw32" ]; then 32 if [ ${TARGET_OS} = "mingw32" ]; then
31 # There are no arch specific syscfg files for mingw32 33 # There are no arch specific syscfg files for mingw32
32 TARGET_FILE= 34 TARGET_FILE=
35 elif [ ${TARGET_ARCH} = "arc" ]; then
36 # ARC syscfg file is automatically aliased to i686-pc-linux-gnu
37 TARGET_FILE=
33 elif [ ${TARGET_OS} != "linux" ]; then 38 elif [ ${TARGET_OS} != "linux" ]; then
34 TARGET_FILE=${TARGET_OS} 39 TARGET_FILE=${TARGET_OS}
35 fi 40 fi
@@ -38,11 +43,11 @@ do_compile_prepend() {
38 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;; 43 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
39 arm) TUPLE=arm-unknown-linux-gnueabi ;; 44 arm) TUPLE=arm-unknown-linux-gnueabi ;;
40 armeb) TUPLE=arm-unknown-linux-gnueabi ;; 45 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
41 i586|i686) TUPLE=i686-pc-linux-gnu ;; 46 i586|i686) TUPLE=i686-unknown-linux-gnu;;
42 mips64*) TUPLE=mips64el-unknown-linux-gnuabi64 ;; 47 mips64*) TUPLE=mips64el-unknown-linux-gnuabi64 ;;
43 mips*el) TUPLE=mipsel-unknown-linux-gnu ;; 48 mips*el) TUPLE=mipsel-unknown-linux-gnu ;;
44 mips*) TUPLE=mips-unknown-linux-gnu ;; 49 mips*) TUPLE=mips-unknown-linux-gnu ;;
45 x86_64) TUPLE=x86_64-pc-linux-gnu ;; 50 x86_64) TUPLE=x86_64-unknown-linux-gnu ;;
46 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;; 51 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
47 esac 52 esac
48 53