summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-07-27 16:02:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-01 11:47:12 +0100
commite7a0997f19da28972b03ae7df15062d9dbdd4270 (patch)
treeb970721020e2c62bbc77e79a6d4bc8b265073b57 /meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
parent3486b729b252d04b96ebeeca7148f23fd4e53c67 (diff)
downloadpoky-e7a0997f19da28972b03ae7df15062d9dbdd4270.tar.gz
libgpg-error: upgrade to 1.24
1.23 -> 1.24 (From OE-Core rev: 4e951b202a5cc2c8d734a9082389435265213be2) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.24.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.24.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
new file mode 100644
index 0000000000..e45a7b860a
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=23;md5=cf562f60b9dba7df20d6ee3f97ea1d5a \
9 file://src/init.c;endline=20;md5=872b2389fe9bae7ffb80d2b91225afbc"
10
11
12SECTION = "libs"
13
14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
16 file://pkgconfig.patch \
17 "
18SRC_URI[md5sum] = "feb42198c0aaf3b28eabe8f41a34b983"
19SRC_URI[sha256sum] = "9268e1cc487de5e6e4460fca612a06e4f383072ac43ae90603e5e46783d3e540"
20
21BINCONFIG = "${bindir}/gpg-error-config"
22
23inherit autotools binconfig-disabled pkgconfig gettext
24CPPFLAGS += "-P"
25do_compile_prepend() {
26 TARGET_FILE=linux-gnu
27 if [ ${TARGET_OS} != "linux" ]; then
28 TARGET_FILE=${TARGET_OS}
29 fi
30
31 case ${TARGET_ARCH} in
32 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
33 arm) TUPLE=arm-unknown-linux-gnueabi ;;
34 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
35 i586|i686) TUPLE=i686-pc-linux-gnu ;;
36 mips64el) TUPLE=mipsel-unknown-linux-gnu ;;
37 mips64) TUPLE=mips-unknown-linux-gnu ;;
38 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
39 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
40 esac
41
42 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
43 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
44}
45
46do_install_append() {
47 # we don't have common lisp in OE
48 rm -rf "${D}${datadir}/common-lisp/"
49}
50
51FILES_${PN}-dev += "${bindir}/gpg-error"
52
53BBCLASSEXTEND = "native"