summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-16 04:31:19 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-18 10:40:27 +0100
commit80cecb6cc9a3765aeb8dd4060a4a994c2625a952 (patch)
tree687b97211403f043b288d3376e50e97737f9e051 /meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
parent70de26076f36205b914be1b1911e5fc0afd65edb (diff)
downloadpoky-80cecb6cc9a3765aeb8dd4060a4a994c2625a952.tar.gz
libgcrypt: 1.7.8 -> 1.8.0
Rebase patches: - add-pkgconfig-support.patch -> 0001 - libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch -> 0002 - fix-ICE-failure-on-mips-with-option-O-and-g.patch -> 0003 - fix-undefined-reference-to-pthread.patch -> 0004 (From OE-Core rev: b90037da8754009ca7cf2ab996b46b3dae1eb204) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
new file mode 100644
index 0000000000..1797d9584d
--- /dev/null
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.8.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
14
15DEPENDS = "libgpg-error"
16
17UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
18SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.gz \
19 file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \
20 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
21 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
22 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
23"
24SRC_URI[md5sum] = "110ce4352f9ea6f560bdc6c5644ae93c"
25SRC_URI[sha256sum] = "f6e470b7f2d3a703e8747f05a8c19d9e10e26ebf2d5f3d71ff75a40f504e12ee"
26
27BINCONFIG = "${bindir}/libgcrypt-config"
28
29inherit autotools texinfo binconfig-disabled pkgconfig
30
31EXTRA_OECONF = "--disable-asm"
32EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
33
34PACKAGECONFIG ??= "capabilities"
35PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
36
37do_configure_prepend () {
38 # Else this could be used in preference to the one in aclocal-copy
39 rm -f ${S}/m4/gpg-error.m4
40}
41
42# libgcrypt.pc is added locally and thus installed here
43do_install_append() {
44 install -d ${D}/${libdir}/pkgconfig
45 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
46}
47
48PACKAGES =+ "dumpsexp-dev"
49
50FILES_${PN}-dev += "${bindir}/hmac256"
51FILES_dumpsexp-dev += "${bindir}/dumpsexp"
52
53BBCLASSEXTEND = "native nativesdk"