summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-02 18:54:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-04 12:30:58 +0000
commit991e2b5879c43ffb384530fe01639004df872206 (patch)
tree2afcdd1f79e5bf722c196c96b76316a3d7805977 /meta/recipes-support/libffi/libffi_3.3.bb
parentc96f31006da285fa016cfdb05390cb50b09fe077 (diff)
downloadpoky-991e2b5879c43ffb384530fe01639004df872206.tar.gz
libffi: update to 3.3 final
Add a couple patches to address ppc(64) build failures. License-Update: copyright years (From OE-Core rev: 9aab37ac40c8da5121a931f5979fcc88489021d2) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libffi/libffi_3.3.bb')
-rw-r--r--meta/recipes-support/libffi/libffi_3.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.3.bb b/meta/recipes-support/libffi/libffi_3.3.bb
new file mode 100644
index 0000000000..f57d03d2f5
--- /dev/null
+++ b/meta/recipes-support/libffi/libffi_3.3.bb
@@ -0,0 +1,39 @@
1SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=492385fe22195952f5b9b197868ba268"
12
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
15 file://0001-Fixed-missed-ifndef-for-__mips_soft_float.patch \
16 file://0001-powerpc-fix-build-failure-on-power7-and-older-532.patch \
17 file://0001-Address-platforms-with-no-__int128.patch \
18 "
19SRC_URI[md5sum] = "6313289e32f1d38a9df4770b014a2ca7"
20SRC_URI[sha256sum] = "72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056"
21UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
22UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
23
24EXTRA_OECONF += "--disable-builddir"
25EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
26inherit autotools texinfo multilib_header
27
28do_install_append() {
29 oe_multilib_header ffi.h
30}
31
32FILES_${PN}-dev += "${libdir}/libffi-${PV}"
33
34# Doesn't compile in MIPS16e mode due to use of hand-written
35# assembly
36MIPS_INSTRUCTION_SET = "mips"
37
38BBCLASSEXTEND = "native nativesdk"
39