summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libevent/libevent_2.1.10.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-06-19 11:58:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-19 22:13:39 +0100
commitf9ac711afb40b9803be3860983948034e0526c96 (patch)
tree786a76f181402958ad00f00421f2131455f93a0f /meta/recipes-support/libevent/libevent_2.1.10.bb
parent4782ccbbde1ca859e7aa9f8699bd903e9582b585 (diff)
downloadpoky-f9ac711afb40b9803be3860983948034e0526c96.tar.gz
libevent:upgrade 2.1.8 -> 2.1.10
-Upgrade from libevent_2.1.8.bb to libevent_2.1.10.bb. -libevent/0001-test-fix-32bit-linux-regress.patch Removed since this is included in 2.1.10. (From OE-Core rev: 40ea686112e4def38363edb4a5b1cec2692e34da) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libevent/libevent_2.1.10.bb')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.10.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.10.bb b/meta/recipes-support/libevent/libevent_2.1.10.bb
new file mode 100644
index 0000000000..81ceb1cd91
--- /dev/null
+++ b/meta/recipes-support/libevent/libevent_2.1.10.bb
@@ -0,0 +1,46 @@
1SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = " \
10 https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
11 file://Makefile-missing-test-dir.patch \
12 file://run-ptest \
13"
14
15SRC_URI[md5sum] = "999caf86f52943af2363bc8077f00167"
16SRC_URI[sha256sum] = "e864af41a336bb11dab1a23f32993afe963c1f69618bd9292b89ecf6904845b0"
17
18UPSTREAM_CHECK_URI = "http://libevent.org/"
19
20S = "${WORKDIR}/${BPN}-${PV}-stable"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24
25inherit autotools
26
27# Needed for Debian packaging
28LEAD_SONAME = "libevent-2.1.so"
29
30inherit ptest multilib_header
31
32DEPENDS = "zlib"
33
34BBCLASSEXTEND = "native nativesdk"
35
36do_install_append() {
37 oe_multilib_header event2/event-config.h
38}
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
43 do
44 install -m 0755 $file ${D}${PTEST_PATH}/test
45 done
46}