summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-08-21 01:38:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:47:06 +0100
commit8754a006caaa5234313927506782bb2d0df32f04 (patch)
treed61f16da3c76b3e09c5130a9e848ed32306a3e9c /meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb
parent20c6c72ad37df8c2bac118c93705874870dff6b3 (diff)
downloadpoky-8754a006caaa5234313927506782bb2d0df32f04.tar.gz
libcap-ng: add package 0.7.7
Pull package from meta-oe to oe-core: meta-oe commit: bce4dba5546480c8e43c6442959ac7d0a4ef32f6 The libcap-ng library is intended to make programming with posix capabilities much easier than the traditional libcap library. It's not a replacement to libcap, it provides different library (libcap-ng.so) while packages explicitly look for libcap.so. It could be used by qemu, util-linux, libvirt, audit ... With adding it to oe-core, the copies from following layers could be removed: * meta-oe, meta-selinux, meta-security-framework ... (From OE-Core rev: ad509d7644803ff9386affefe2ec1a3664027074) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb b/meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb
new file mode 100644
index 0000000000..a31d5dc437
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng_0.7.7.bb
@@ -0,0 +1,39 @@
1SUMMARY = "An alternate posix capabilities library"
2DESCRIPTION = "The libcap-ng library is intended to make programming \
3with POSIX capabilities much easier than the traditional libcap library."
4HOMEPAGE = "http://freecode.com/projects/libcap-ng"
5SECTION = "base"
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
9
10SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \
11 file://python.patch"
12
13inherit lib_package autotools pythonnative
14
15SRC_URI[md5sum] = "3d7d126b29e2869a0257c17c8b0d9b2e"
16SRC_URI[sha256sum] = "615549ce39b333f6b78baee0c0b4ef18bc726c6bf1cca123dfd89dd963f6d06b"
17
18DEPENDS += "swig-native python"
19
20EXTRA_OECONF += "--without-python3"
21
22EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
23
24PACKAGES += "${PN}-python"
25
26FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug"
27FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
28
29BBCLASSEXTEND = "native"
30
31do_install_append() {
32 # Moving libcap-ng to base_libdir
33 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
34 mkdir -p ${D}/${base_libdir}/
35 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
36 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
37 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
38 fi
39}