summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.4.1.bb
diff options
context:
space:
mode:
authorIonut Radu <ionutx.radu@intel.com>2013-05-08 17:41:59 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-16 00:09:48 +0300
commitca64333d0bc2666eae18dbaa90cebb090cd43a45 (patch)
tree2c6e530c53b57d39fb12128e10e1d59d68fb25c6 /meta/recipes-support/gpgme/gpgme_1.4.1.bb
parentc066df89474b59188da0ad4a82139a007fdce815 (diff)
downloadpoky-ca64333d0bc2666eae18dbaa90cebb090cd43a45.tar.gz
gpgme: Updated from 1.4.0 to 1.4.1
(From OE-Core rev: 775529a3891d3f3317ff79b0b1bd2f196f7fa2e8) Signed-off-by: Ionut Radu <ionutx.radu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.4.1.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.1.bb b/meta/recipes-support/gpgme/gpgme_1.4.1.bb
new file mode 100644
index 0000000000..13bc508aa9
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.4.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "High-level GnuPG encryption/signing API"
2DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
3HOMEPAGE = "http://www.gnupg.org/gpgme.html"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
9 file://src/gpgme.h.in;endline=23;md5=a7b9706396e8e12c17be7d8d556ef7a5 \
10 file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
11
12SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
13 file://disable_gpgconf_check.patch"
14
15SRC_URI[md5sum] = "07f1c0eb6596a94efa3ffb75e74bfbba"
16SRC_URI[sha256sum] = "7ab63e5086ebe4cfe7f78face1bb059a7a60da586b1e5c6a77bedcd6d04019b8"
17DEPENDS = "libgpg-error libassuan ${PTH}"
18PTH_libc-uclibc = "npth"
19PTH = "pth"
20
21EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
22 --with-gpg=${bindir}/gpg --without-gpgsm"
23
24inherit autotools binconfig
25
26PACKAGES =+ "${PN}-pth ${PN}-pthread"
27FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
28FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
29FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"