summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.3.2.bb
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2012-06-22 15:27:53 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-25 16:35:52 +0100
commitaecbfbc0abd584aa1a08cd655eae6e1f99b2a60c (patch)
treec5e3527ef30a1a5e9ef570e321858716c9a1078b /meta/recipes-support/gpgme/gpgme_1.3.2.bb
parent0abfb690a847df660726103157d7dc50a57286ec (diff)
downloadpoky-aecbfbc0abd584aa1a08cd655eae6e1f99b2a60c.tar.gz
gpgme: updated to 1.3.2
Licence update: the same licence and new copyright years added (From OE-Core rev: 0328d64cdf1daf2deee0ddc2a3aa3bbc8b812096) Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.3.2.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.3.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.3.2.bb b/meta/recipes-support/gpgme/gpgme_1.3.2.bb
new file mode 100644
index 0000000000..b3c1d469e9
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.3.2.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
2HOMEPAGE = "http://www.gnupg.org/gpgme.html"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
8 file://src/gpgme.h.in;endline=23;md5=00846fee29ec2a6f5c808bfe7fc24e65 \
9 file://src/engine.h;endline=22;md5=e96acfaab1cff82dd8fbefddd2f5c436"
10
11SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
12 file://disable_gpgconf_check.patch"
13
14SRC_URI[md5sum] = "326fe97077141713f0930aa87949a287"
15SRC_URI[sha256sum] = "cfd235663f1d1adc97abb38dd5e6d093bb7e155580f171f9ba0158feab69f875"
16DEPENDS = "libgpg-error libassuan ${PTH}"
17PTH_libc-uclibc = "npth"
18PTH = "pth"
19
20PR = "r0"
21
22EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
23 --with-gpg=${bindir}/gpg --without-gpgsm"
24
25inherit autotools binconfig
26
27PACKAGES =+ "${PN}-pth ${PN}-pthread"
28FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
29FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
30FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
31
32do_install_append() {
33 rmdir ${D}/usr/libexec
34}