summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls/gnutls_3.6.11.1.bb
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-05-02 00:56:26 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-07 17:32:09 +0100
commitebefc69522366487d368df817696e8142fb7bcdc (patch)
treeae514d5acdb5a1b087e51ed212966bce53e5f228 /meta/recipes-support/gnutls/gnutls_3.6.11.1.bb
parent887f299ce983eaf4798b44a8808f2731be68cbe3 (diff)
downloadpoky-ebefc69522366487d368df817696e8142fb7bcdc.tar.gz
gnutls: upgrade 3.6.8 -> 3.6.11.1
Drop patch from 81485be19b18 ("gnutls: don't use HOSTTOOLS_DIR/bash as a shell on target") as upstream now honours POSIX_SHELL when set as the primary target shell. (From OE-Core rev: bc487ced3be40569157fb40c99bfa68871f74744) (From OE-Core rev: f4f933297a77f99783f9a5fb571503e1f45ad259) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_3.6.11.1.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.6.11.1.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_3.6.11.1.bb b/meta/recipes-support/gnutls/gnutls_3.6.11.1.bb
new file mode 100644
index 0000000000..5b05364c25
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls_3.6.11.1.bb
@@ -0,0 +1,67 @@
1SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
22"
23
24SRC_URI[md5sum] = "3670ee0b0d95b3dee185eff2dc910ee7"
25SRC_URI[sha256sum] = "fbba12f3db9a55dbf027e14111755817ec44b57eabec3e8089aac8ac6f533cf8"
26
27inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
28
29PACKAGECONFIG ??= "libidn"
30
31# You must also have CONFIG_SECCOMP enabled in the kernel for
32# seccomp to work.
33PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
34PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
35PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
36PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
37PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
38
39EXTRA_OECONF = " \
40 --enable-doc \
41 --disable-libdane \
42 --disable-guile \
43 --disable-rpath \
44 --enable-local-libopts \
45 --enable-openssl-compatibility \
46 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
47 --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \
48"
49
50# Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell.
51export POSIX_SHELL="${base_bindir}/sh"
52
53LDFLAGS_append_libc-musl = " -largp"
54
55do_configure_prepend() {
56 for dir in . lib; do
57 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
58 done
59}
60
61PACKAGES =+ "${PN}-openssl ${PN}-xx"
62
63FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
64FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
65FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
66
67BBCLASSEXTEND = "native nativesdk"