summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.2.9.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-09-19 14:44:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-06 16:26:52 +0000
commitfffac6b38a56f636e5a916696a2fbe7c6dfb70b2 (patch)
tree83cdb26b7b04dcb417bde58d0b4398856ff3aac0 /meta/recipes-support/gnupg/gnupg_2.2.9.bb
parent77f078eebbd80d4aee69a02c256d14183886b144 (diff)
downloadpoky-fffac6b38a56f636e5a916696a2fbe7c6dfb70b2.tar.gz
gnupg: patch gnupg-native to allow path relocation
GnuPG hard-codes $bindir etc and uses them to find the helper binaries, such as gpg-agent. This breaks if gnupg-native is reused from sstate for a different build directory and GPG signing of packages is required. Patch in getenv() checks for gnupg-native when returning the hardcoded paths, and create a wrapper script which overrides GNUPG_BINDIR. There are more paths that can be overridden, but this one is sufficient to make GnuPG work. (From OE-Core rev: dfd69ff889ed78bf137116583d8ae351859ee203) (From OE-Core rev: e0cc225fc5bbc964f0f41ee0ca29e6b7b5ebef41) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.9.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.9.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.9.bb b/meta/recipes-support/gnupg/gnupg_2.2.9.bb
index 4f815dff20..b7d23b8d39 100644
--- a/meta/recipes-support/gnupg/gnupg_2.2.9.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.2.9.bb
@@ -15,7 +15,8 @@ SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://0003-dirmngr-uses-libgpg-error.patch \ 15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \ 16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 " 17 "
18SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch" 18SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
19 file://relocate.patch"
19 20
20 21
21SRC_URI[md5sum] = "52c895a81f514a65e08923736c38654a" 22SRC_URI[md5sum] = "52c895a81f514a65e08923736c38654a"
@@ -43,6 +44,10 @@ do_install_append() {
43 ln -sf gpgv2 ${D}${bindir}/gpgv 44 ln -sf gpgv2 ${D}${bindir}/gpgv
44} 45}
45 46
47do_install_append_class-native() {
48 create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
49}
50
46PACKAGECONFIG ??= "gnutls" 51PACKAGECONFIG ??= "gnutls"
47PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls" 52PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
48PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3" 53PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"