summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.1.7.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-08-19 23:04:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:35:47 +0100
commitdb1b3df63f1b64f7842e9539fa145164f52fdae9 (patch)
tree8e08d4c930babea94c3a34ea9a61223e4b226619 /meta/recipes-support/gnupg/gnupg_2.1.7.bb
parent14d44456ad5b9f280772a712d8a5312a5dee8d55 (diff)
downloadpoky-db1b3df63f1b64f7842e9539fa145164f52fdae9.tar.gz
gnupg: 2.1.6 -> 2.1.7
(From OE-Core rev: 78b159bf753c43c78bb0f283add7d447b96e08f1) (From OE-Core rev: 1054d5c0c0353b2ae89ab70232055eec759ccd43) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.1.7.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.1.7.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.1.7.bb b/meta/recipes-support/gnupg/gnupg_2.1.7.bb
new file mode 100644
index 0000000000..48c7c9622d
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.1.7.bb
@@ -0,0 +1,41 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
5 file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://pkgconfig.patch \
13 file://use-pkgconfig-instead-of-npth-config.patch \
14 file://dirmngr-uses-libgpg-error.patch \
15 "
16
17SRC_URI[md5sum] = "ebdf92b15b8bcd8579b643c7f41a3238"
18SRC_URI[sha256sum] = "c18a3776d47fec98892d51d28b6574ef16bf0a25eabb0956231058aaf2e7846e"
19
20EXTRA_OECONF = "--disable-ldap \
21 --disable-ccid-driver \
22 --with-zlib=${STAGING_LIBDIR}/.. \
23 --with-bzip2=${STAGING_LIBDIR}/.. \
24 --with-readline=${STAGING_LIBDIR}/.. \
25 "
26RRECOMMENDS_${PN} = "pinentry"
27
28do_configure_prepend () {
29 # Else these could be used in prefernce to those in aclocal-copy
30 rm -f ${S}/m4/gpg-error.m4
31 rm -f ${S}/m4/libassuan.m4
32 rm -f ${S}/m4/ksba.m4
33 rm -f ${S}/m4/libgcrypt.m4
34}
35
36do_install_append() {
37 ln -sf gpg2 ${D}${bindir}/gpg
38 ln -sf gpgv2 ${D}${bindir}/gpgv
39}
40
41RDEPENDS_${PN} = "gnutls"