summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.1.23.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-21 05:49:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 08:47:02 +0100
commitc55b3706124ef0298be3697a4dcf1fc121f45d75 (patch)
tree856b91a081960bfe41a1579f1809765428fa8952 /meta/recipes-support/gnupg/gnupg_2.1.23.bb
parent624da0cc25cd3fb352fa58ee69bb52d66aa0ad66 (diff)
downloadpoky-c55b3706124ef0298be3697a4dcf1fc121f45d75.tar.gz
gnupg: 2.1.20 -> 2.1.23
1. COPYING.LIB: Rename to COPYING.LGPL3. https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=3419a339d9c4e800bf30e9021e05982d8c1021c1 2. Rebase patches: - pkgconfig.patch -> 0001 - use-pkgconfig-instead-of-npth-config.patch -> 0002 - dirmngr-uses-libgpg-error.patch -> 0003 - autogen.sh-fix-find-version-for-beta-checking.patch -> 0004 3. Fix gpg2 not found ... dnf -vy makecache |Cannot download 'http://192.168.7.1:33541': repomd.xml GPG signature verification error: gpgme_engine_check_version() error: Invalid crypto engine. ... The upstream install gpg by default and no gpg2 ... commit a69464b0b6dac88b360a13d3faf19dd7f2a0e02b Author: Werner Koch <wk@gnupg.org> Date: Sat Aug 5 14:39:32 2017 +0200 gpg: Install gpg by default under the name gpg. ... Add --enable-gpg-is-gpg2 to revert it. (From OE-Core rev: f62d844424670967d2d40cd2afc96f5fc597bf1d) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.1.23.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.1.23.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.1.23.bb b/meta/recipes-support/gnupg/gnupg_2.1.23.bb
new file mode 100644
index 0000000000..8cbe5e12f8
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.1.23.bb
@@ -0,0 +1,46 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 "
18
19SRC_URI[md5sum] = "86c2304ead54b74a422e76c3f1bc7a91"
20SRC_URI[sha256sum] = "a94476391595e9351f219188767a9d6ea128e83be5ed3226a7890f49aa2d0d77"
21
22EXTRA_OECONF = "--disable-ldap \
23 --disable-ccid-driver \
24 --with-zlib=${STAGING_LIBDIR}/.. \
25 --with-bzip2=${STAGING_LIBDIR}/.. \
26 --with-readline=${STAGING_LIBDIR}/.. \
27 --enable-gpg-is-gpg2 \
28 "
29RRECOMMENDS_${PN} = "pinentry"
30
31do_configure_prepend () {
32 # Else these could be used in prefernce to those in aclocal-copy
33 rm -f ${S}/m4/gpg-error.m4
34 rm -f ${S}/m4/libassuan.m4
35 rm -f ${S}/m4/ksba.m4
36 rm -f ${S}/m4/libgcrypt.m4
37}
38
39do_install_append() {
40 ln -sf gpg2 ${D}${bindir}/gpg
41 ln -sf gpgv2 ${D}${bindir}/gpgv
42}
43
44PACKAGECONFIG ??= "gnutls"
45PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
46PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"