summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.0.26.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-08-19 07:49:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 09:26:09 +0100
commit1fb5d64a84d072dbbf36c9d8fe65098c138c4b0d (patch)
treeac335b61e403de221367f913e2a1776d0b5d9ee1 /meta/recipes-support/gnupg/gnupg_2.0.26.bb
parent088123da66c09194e4b92f9c8404ff345eb2f5ac (diff)
downloadpoky-1fb5d64a84d072dbbf36c9d8fe65098c138c4b0d.tar.gz
gnupg: Upgrade to 2.0.26
(From OE-Core rev: c4c3fe15f25de560e63800bc50584e511b4cb84d) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.0.26.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.0.26.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.0.26.bb b/meta/recipes-support/gnupg/gnupg_2.0.26.bb
new file mode 100644
index 0000000000..c460b7e1fa
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.0.26.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
5 file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6"
6
7DEPENDS = "${PTH} libassuan libksba zlib bzip2 readline libgcrypt"
8PTH = "pth"
9PTH_libc-uclibc = "npth"
10
11inherit autotools gettext texinfo pkgconfig
12
13SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2 \
14 file://pkgconfig.patch"
15
16SRC_URI[md5sum] = "fa7e704aad33eb114d1840164455aec1"
17SRC_URI[sha256sum] = "7758e30dc382ae7a7167ed41b7f936aa50af5ea2d6fccdef663b5b750b65b8e0"
18
19EXTRA_OECONF = "--disable-ldap \
20 --disable-ccid-driver \
21 --without-libcurl \
22 --with-zlib=${STAGING_LIBDIR}/.. \
23 --with-bzip2=${STAGING_LIBDIR}/.. \
24 --with-readline=${STAGING_LIBDIR}/.. \
25 "
26
27do_configure_prepend () {
28 # Else these could be used in prefernce to those in aclocal-copy
29 rm -f ${S}/m4/gpg-error.m4
30 rm -f ${S}/m4/libassuan.m4
31 rm -f ${S}/m4/ksba.m4
32 rm -f ${S}/m4/libgcrypt.m4
33}
34
35do_install_append() {
36 ln -sf gpg2 ${D}${bindir}/gpg
37 ln -sf gpgv2 ${D}${bindir}/gpgv
38}