summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gmp/gmp_6.1.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-06 18:37:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-12 23:10:14 +0100
commit4de8b37aa66bb676bd2176496cce6f5f0784d12b (patch)
tree64c84f9765eb0291fab395dfa7c012d05e0182ef /meta/recipes-support/gmp/gmp_6.1.1.bb
parent65a8f241e1b6576263c743a93a70018dd08c9902 (diff)
downloadpoky-4de8b37aa66bb676bd2176496cce6f5f0784d12b.tar.gz
gmp: 6.1.0 -> 6.1.1
(From OE-Core rev: 55fea8ead3ebef7e28a982a7721bc0ec42b5ca86) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gmp/gmp_6.1.1.bb')
-rw-r--r--meta/recipes-support/gmp/gmp_6.1.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/gmp/gmp_6.1.1.bb b/meta/recipes-support/gmp/gmp_6.1.1.bb
new file mode 100644
index 0000000000..1df9b06cc8
--- /dev/null
+++ b/meta/recipes-support/gmp/gmp_6.1.1.bb
@@ -0,0 +1,37 @@
1require gmp.inc
2
3LICENSE = "GPLv2+ | LGPLv3+"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
6 file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
7 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8"
9
10REVISION = ""
11SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \
12 file://amd64.patch \
13 file://use-includedir.patch \
14 file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \
15 "
16
17SRC_URI[md5sum] = "4c175f86e11eb32d8bf9872ca3a8e11d"
18SRC_URI[sha256sum] = "a8109865f2893f1373b0a8ed5ff7429de8db696fc451b1036bd7bdf95bbeffd6"
19
20acpaths = ""
21
22EXTRA_OECONF += " --enable-cxx=detect"
23
24PACKAGES =+ "libgmpxx"
25FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
26
27do_install_append_class-target() {
28 sed -i "s|--sysroot=${STAGING_DIR_HOST}||g" ${D}${includedir}/gmp.h
29}
30
31SSTATE_SCAN_FILES += "gmp.h"
32
33# Doesn't compile in MIPS16e mode due to use of hand-written
34# assembly
35MIPS_INSTRUCTION_SET = "mips"
36
37BBCLASSEXTEND = "native nativesdk"