summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.18.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-11-22 16:41:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-23 23:35:18 +0000
commita15b8cb1fe359510c1a9ae2a88381e87549f92eb (patch)
tree3a202a3b393ff4e80fa516192e02b501e7258379 /meta/recipes-support/gdbm/gdbm_1.18.1.bb
parent691e3069941db750261a85ed8c7f8a506bbe9b3e (diff)
downloadpoky-a15b8cb1fe359510c1a9ae2a88381e87549f92eb.tar.gz
gdbm: update to 1.18.1
(From OE-Core rev: 7fa0996f39f55dbc3c4441d8df7ff2aff17fc6b7) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.18.1.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.18.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.18.1.bb b/meta/recipes-support/gdbm/gdbm_1.18.1.bb
new file mode 100644
index 0000000000..16ecc506ce
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.18.1.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
11 "
12
13SRC_URI[md5sum] = "988dc82182121c7570e0cb8b4fcd5415"
14SRC_URI[sha256sum] = "86e613527e5dba544e73208f42b78b7c022d4fa5a6d5498bf18c8d6f745b91dc"
15
16inherit autotools gettext texinfo lib_package ptest
17
18# Needed for dbm python module
19EXTRA_OECONF = "-enable-libgdbm-compat"
20
21# Stop presence of dbm/nbdm on the host contaminating builds
22CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
23
24BBCLASSEXTEND = "native nativesdk"
25
26do_install_append () {
27 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
28 # these headers
29 install -d ${D}${includedir}/gdbm
30 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
31 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
32}
33
34RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
35
36do_compile_ptest() {
37 oe_runmake -C tests buildtests
38}
39
40PACKAGES =+ "${PN}-compat \
41 "
42FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
43 "