summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.11.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-12-28 10:10:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:13:54 +0000
commit6fd9efcf968334d778a8eb5a96f0c5a059229c6b (patch)
tree1beda7b3d4cf4bf626a6907703baf9d8deb3aff2 /meta/recipes-support/gdbm/gdbm_1.11.bb
parentfce85451b39fd6a12280f013d196987430570ce9 (diff)
downloadpoky-6fd9efcf968334d778a8eb5a96f0c5a059229c6b.tar.gz
gdbm: upgrade to 1.11
(From OE-Core rev: 6c755add9e94d80d0f471eeecabe3de587136066) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.11.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.11.bb b/meta/recipes-support/gdbm/gdbm_1.11.bb
new file mode 100644
index 0000000000..de32e873cb
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.11.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "72c832680cf0999caedbe5b265c8c1bd"
11SRC_URI[sha256sum] = "8d912f44f05d0b15a4a5d96a76f852e905d051bb88022fcdfd98b43be093e3c3"
12
13inherit autotools gettext lib_package
14
15# Needed for dbm python module
16EXTRA_OECONF = "-enable-libgdbm-compat"
17
18# Stop presence of dbm/nbdm on the host contaminating builds
19CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
20
21BBCLASSEXTEND = "native nativesdk"
22
23do_install_append () {
24 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
25 # these headers
26 install -d ${D}${includedir}/gdbm
27 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
28 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
29}
30
31PACKAGES =+ "${PN}-compat \
32 "
33FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
34 "