summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.10.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:38:32 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:50:20 +0100
commite2e6f6fe07049f33cb6348780fa975162752e421 (patch)
treeb1813295411235d1297a0ed642b1346b24fdfb12 /meta/recipes-support/gdbm/gdbm_1.10.bb
downloadpoky-e2e6f6fe07049f33cb6348780fa975162752e421.tar.gz
initial commit of Enea Linux 3.1
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.10.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.10.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.10.bb b/meta/recipes-support/gdbm/gdbm_1.10.bb
new file mode 100644
index 0000000000..c01b6a6331
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.10.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "GNU dbm is a set of database routines that use extensible hashing."
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7PR = "r3"
8
9SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
10 file://run-ptest \
11 file://ptest.patch \
12 "
13
14SRC_URI[md5sum] = "88770493c2559dc80b561293e39d3570"
15SRC_URI[sha256sum] = "23f8134c5b94bbfb06d756a6b78f074fba6e6028cf2fe01341d40b26db773441"
16
17inherit autotools gettext lib_package ptest
18
19# Needed for dbm python module
20EXTRA_OECONF = "-enable-libgdbm-compat"
21
22# Stop presence of dbm/nbdm on the host contaminating builds
23CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
24
25BBCLASSEXTEND = "native nativesdk"
26
27do_install_append () {
28 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
29 # these headers
30 install -d ${D}${includedir}/gdbm
31 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
32 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
33}
34
35RDEPENDS_${PN}-ptest += "diffutils"
36
37do_compile_ptest() {
38 oe_runmake -C tests buildtests
39}
40
41PACKAGES =+ "${PN}-compat \
42 "
43FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
44 "