summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/dos2unix/dos2unix_7.4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-12 19:14:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-16 23:25:49 +0000
commit2bb1f5362ba675e0b07b2bae2ce0c0b8ba6ed5d9 (patch)
tree767ecd43aa8dfae7cae54c0801104449188a8384 /meta/recipes-support/dos2unix/dos2unix_7.4.1.bb
parentba4dbacedd635d2467da1d6038874f4a05f5d2d0 (diff)
downloadpoky-2bb1f5362ba675e0b07b2bae2ce0c0b8ba6ed5d9.tar.gz
dos2unix: update to 7.4.1
License-Update: copyright years (From OE-Core rev: 248e777ac61e90da061e336acbcd23e8e71cd0e4) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/dos2unix/dos2unix_7.4.1.bb')
-rw-r--r--meta/recipes-support/dos2unix/dos2unix_7.4.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/dos2unix/dos2unix_7.4.1.bb b/meta/recipes-support/dos2unix/dos2unix_7.4.1.bb
new file mode 100644
index 0000000000..1623285fd0
--- /dev/null
+++ b/meta/recipes-support/dos2unix/dos2unix_7.4.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Convert text file line endings between CRLF and LF"
2DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
3unix2dos to convert plain text files in DOS or Mac format to Unix \
4format and vice versa."
5HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
6SECTION = "support"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.txt;md5=0c977b18f0a384d03597a517d7d03e32"
10
11SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
12UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))"
13
14SRCREV = "0490f0723b1a0851b17343f6164915f3474b5197"
15
16S = "${WORKDIR}/git/dos2unix"
17
18inherit gettext perlnative
19
20# The dos2unix NLS relies on po4a-native, while po4a recipe is
21# provided by meta-perl layer, so make it optional here, you
22# need have meta-perl in bblayers.conf before enabling nls in
23# PACKAGECONFIG.
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
26
27EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
28EXTRA_OEMAKE_class-native = "ENABLE_NLS="
29
30do_install () {
31 oe_runmake DESTDIR="${D}${base_prefix}" install
32}
33
34BBCLASSEXTEND = "native nativesdk"