summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.9.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-05 15:26:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:42 +0000
commit669b0f4c55c5bf8f83d203e03115c496dd929ca6 (patch)
tree4d74b2252b49df5408383b8ad10a5221fe282a5b /meta/recipes-support/debianutils/debianutils_4.9.1.bb
parent5fd13c61420cdeb93b4095b0c8d4bf8cd83a08cd (diff)
downloadpoky-669b0f4c55c5bf8f83d203e03115c496dd929ca6.tar.gz
debianutils: update to 4.9.1
(From OE-Core rev: d1d913faf649660a18225bf1d411ace2419c6d26) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.9.1.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.9.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.9.1.bb b/meta/recipes-support/debianutils/debianutils_4.9.1.bb
new file mode 100644
index 0000000000..904c52780f
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_4.9.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20191212T145612Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[md5sum] = "95633416680bfd249b7cb07d94137048"
12SRC_URI[sha256sum] = "af826685d9c56abfa873e84cd392539cd363cb0ba04a09d21187377e1b764091"
13
14inherit autotools update-alternatives
15
16do_configure_prepend() {
17 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
18}
19
20do_install_append() {
21 if [ "${base_bindir}" != "${bindir}" ]; then
22 # Debian places some utils into ${base_bindir} as does busybox
23 install -d ${D}${base_bindir}
24 for app in run-parts tempfile; do
25 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
26 done
27 fi
28}
29
30# Note that we package the update-alternatives name.
31#
32PACKAGES =+ "${PN}-run-parts"
33FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
34
35RDEPENDS_${PN} += "${PN}-run-parts"
36RDEPENDS_${PN}_class-native = ""
37
38ALTERNATIVE_PRIORITY="30"
39ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
40
41ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
42ALTERNATIVE_${PN}-run-parts = "run-parts"
43
44ALTERNATIVE_${PN}-doc = "which.1"
45ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
46
47ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
48ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
49ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
50ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
51ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
52ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
53ALTERNATIVE_LINK_NAME[which]="${bindir}/which"
54
55BBCLASSEXTEND = "native"