summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.8.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-06 18:37:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-12 23:10:14 +0100
commit56e23aeb1a3ef32af9d2895513fb7db581f141cb (patch)
tree1258ac76c09042d87b3d4c452750f3ef6ab13343 /meta/recipes-support/debianutils/debianutils_4.8.bb
parent4de8b37aa66bb676bd2176496cce6f5f0784d12b (diff)
downloadpoky-56e23aeb1a3ef32af9d2895513fb7db581f141cb.tar.gz
debianutils: 4.7 -> 4.8
(From OE-Core rev: 362ba287eecec475203367f65f9cb20c783cda8d) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.8.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.8.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.8.bb b/meta/recipes-support/debianutils/debianutils_4.8.bb
new file mode 100644
index 0000000000..d969fd3c9a
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_4.8.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20160629T224408Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[md5sum] = "66a37e5ff17be431319bd0b43e9a46b5"
12SRC_URI[sha256sum] = "afa95bbe6b6fd3ef3c0c838b2d7232f09fabeff593ca4b5583cffa6748567ee2"
13
14inherit autotools update-alternatives
15
16do_configure_prepend() {
17 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
18}
19
20do_install_append() {
21 if [ "${base_bindir}" != "${bindir}" ]; then
22 # Debian places some utils into ${base_bindir} as does busybox
23 install -d ${D}${base_bindir}
24 for app in run-parts tempfile; do
25 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
26 done
27 fi
28}
29
30# Note that we package the update-alternatives name.
31#
32PACKAGES =+ "${PN}-run-parts"
33FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
34
35RDEPENDS_${PN} += "${PN}-run-parts"
36
37
38ALTERNATIVE_PRIORITY="30"
39ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
40ALTERNATIVE_${PN}-run-parts = "run-parts"
41
42ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
43ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
44ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
45ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
46ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
47ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
48ALTERNATIVE_LINK_NAME[which]="${bindir}/which"