diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-02-17 10:12:51 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-02-18 07:39:31 +0000 |
commit | f37ac5ba2f9c1dc4d8c70145f5b12b417da000a9 (patch) | |
tree | 555f879ce4759c080237f28c62dddaa742258d46 /meta/recipes-support/debianutils/debianutils_4.7.bb | |
parent | adfcaf27406000d9124680fd4147995735ba5e4d (diff) | |
download | poky-f37ac5ba2f9c1dc4d8c70145f5b12b417da000a9.tar.gz |
debianutils: Upgrade 4.5.1 -> 4.7
Tarball now uses the standard ${BPN}-${PV} so drop custom S setting.
(From OE-Core rev: 4c05c5e2d9fce43b815a8fd6a8bb256d94e54732)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.7.bb')
-rw-r--r-- | meta/recipes-support/debianutils/debianutils_4.7.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.7.bb b/meta/recipes-support/debianutils/debianutils_4.7.bb new file mode 100644 index 0000000000..6a1d5bf83d --- /dev/null +++ b/meta/recipes-support/debianutils/debianutils_4.7.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "Miscellaneous utilities specific to Debian" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2 & SMAIL_GPL" | ||
4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f" | ||
5 | |||
6 | SRC_URI = "http://snapshot.debian.org/archive/debian/20160204T040501Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz" | ||
7 | # the package is taken from snapshots.debian.org; that source is static and goes stale | ||
8 | # so we check the latest upstream from a directory that does get updated | ||
9 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/" | ||
10 | |||
11 | SRC_URI[md5sum] = "00186f527b35e2cecd4db593c6d512d0" | ||
12 | SRC_URI[sha256sum] = "a269cacd40f52f2fa5d5636357714a49e8538459c16d77772efaa23711fe53d9" | ||
13 | |||
14 | inherit autotools update-alternatives | ||
15 | |||
16 | do_configure_prepend() { | ||
17 | sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am | ||
18 | } | ||
19 | |||
20 | do_install_append() { | ||
21 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
22 | # Debian places some utils into ${base_bindir} as does busybox | ||
23 | install -d ${D}${base_bindir} | ||
24 | for app in run-parts tempfile; do | ||
25 | mv ${D}${bindir}/$app ${D}${base_bindir}/$app | ||
26 | done | ||
27 | fi | ||
28 | } | ||
29 | |||
30 | # Note that we package the update-alternatives name. | ||
31 | # | ||
32 | PACKAGES =+ "${PN}-run-parts" | ||
33 | FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils" | ||
34 | |||
35 | RDEPENDS_${PN} += "${PN}-run-parts" | ||
36 | |||
37 | |||
38 | ALTERNATIVE_PRIORITY="30" | ||
39 | ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which" | ||
40 | ALTERNATIVE_${PN}-run-parts = "run-parts" | ||
41 | |||
42 | ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell" | ||
43 | ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel" | ||
44 | ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell" | ||
45 | ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts" | ||
46 | ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog" | ||
47 | ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile" | ||
48 | ALTERNATIVE_LINK_NAME[which]="${bindir}/which" | ||