summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.5.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-02 02:51:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:38:49 +0100
commit46ccf0a8f0c8e1036dc2da17bc68034a2793a160 (patch)
tree1451cb8d122766ed78e2e5483c23a6c048158ef4 /meta/recipes-support/debianutils/debianutils_4.5.1.bb
parent5143631eaf1225e1832a72fe0938ef70c9e77f1c (diff)
downloadpoky-46ccf0a8f0c8e1036dc2da17bc68034a2793a160.tar.gz
debianutils: 4.5 -> 4.5.1
(From OE-Core rev: d713080a3299de2d5bffaed7469b1cb9ae1ca107) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.5.1.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.5.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.5.1.bb b/meta/recipes-support/debianutils/debianutils_4.5.1.bb
new file mode 100644
index 0000000000..9e5dd702f8
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_4.5.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7
8SRC_URI[md5sum] = "487524518cd5833a6a4f7007b5d1bd5b"
9SRC_URI[sha256sum] = "a531c23e0105fe01cfa928457a8343a1e947e2621b3cd4d05f4e9656020c63b7"
10
11S = "${WORKDIR}/${BPN}"
12
13inherit autotools update-alternatives
14
15do_configure_prepend() {
16 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
17}
18
19do_install_append() {
20 if [ "${base_bindir}" != "${bindir}" ]; then
21 # Debian places some utils into ${base_bindir} as does busybox
22 install -d ${D}${base_bindir}
23 for app in run-parts tempfile; do
24 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
25 done
26 fi
27}
28
29ALTERNATIVE_PRIORITY="100"
30ALTERNATIVE_${PN} = "add-shell installkernel remove-shell run-parts savelog tempfile which"
31
32ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
33ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
34ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
35ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
36ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
37ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
38ALTERNATIVE_LINK_NAME[which]="${bindir}/which"