diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2017-01-02 15:15:55 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-14 14:42:16 +0000 |
commit | f033bba14a221c1e815dffa27c6bda1193a0f119 (patch) | |
tree | 7ffe7755df41e80f10a319fde8a9928bc6a33ef2 /meta/recipes-support/db/db_6.0.35.bb | |
parent | 372bcd3c978524fa2ca31e4fe14f288f67562cdb (diff) | |
download | poky-f033bba14a221c1e815dffa27c6bda1193a0f119.tar.gz |
db: remove the 6.x recipe
Version 6.x of Berkeley DB has been rejected by open source community due to its hostile
AGPLv3 license; both Fedora and Debian are sticking with db 5.x - and by extension,
all the open source projects are still developed and tested with db 5.x
In oe-core the only thing that was requiring db 6.x was rpm 5.x, and so there's no reason
to continue carrying db 6.x in oe-core. If someone needs API features that are only available in
db 6.x, it can be re-added to meta-oe.
(From OE-Core rev: 2694de76542840f79e3953c546d07b8ae479b8a1)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db/db_6.0.35.bb')
-rw-r--r-- | meta/recipes-support/db/db_6.0.35.bb | 111 |
1 files changed, 0 insertions, 111 deletions
diff --git a/meta/recipes-support/db/db_6.0.35.bb b/meta/recipes-support/db/db_6.0.35.bb deleted file mode 100644 index b1bec0e487..0000000000 --- a/meta/recipes-support/db/db_6.0.35.bb +++ /dev/null | |||
@@ -1,111 +0,0 @@ | |||
1 | # Version 6 of the Berkeley DB from Oracle (formerly Sleepycat) | ||
2 | # | ||
3 | # At present this package only installs the DB code | ||
4 | # itself (shared libraries, .a in the dev package), | ||
5 | # documentation and headers. | ||
6 | # | ||
7 | # The headers have the same names as those as v3 | ||
8 | # of the DB, only one version can be used *for dev* | ||
9 | # at once - DB3 and DB6 can both be installed on the | ||
10 | # same system at the same time if really necessary. | ||
11 | SECTION = "libs" | ||
12 | SUMMARY = "Berkeley Database v6" | ||
13 | HOMEPAGE = "http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html" | ||
14 | LICENSE = "AGPL-3.0" | ||
15 | VIRTUAL_NAME ?= "virtual/db" | ||
16 | RCONFLICTS_${PN} = "db3" | ||
17 | |||
18 | PR = "r1" | ||
19 | |||
20 | # Note, when upgraded to 6.1.x, a patch in RPM will need to be removed to activate db 6.1 support. | ||
21 | SRC_URI = "http://distfiles.gentoo.org/distfiles/db-${PV}.tar.gz \ | ||
22 | file://arm-thumb-mutex_db5.patch \ | ||
23 | file://fix-parallel-build.patch \ | ||
24 | file://Makefile-let-libso_target-depend-on-bt_rec.patch \ | ||
25 | file://Makefile-let-libdb-6.0.la-depend-os_map.l.patch \ | ||
26 | " | ||
27 | |||
28 | SRC_URI[md5sum] = "c65a4d3e930a116abaaf69edfc697f25" | ||
29 | SRC_URI[sha256sum] = "24421affa8ae436fe427ae4f5f2d1634da83d3d55a5ad6354a98eeedb825de55" | ||
30 | |||
31 | # Exclude NC versions which lack AES encryption | ||
32 | UPSTREAM_CHECK_REGEX = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar" | ||
33 | UPSTREAM_CHECK_URI = "http://www.oracle.com/technetwork/products/berkeleydb/downloads/index-082944.html" | ||
34 | |||
35 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ec8b0b17cc31513fe35ab10716f8490" | ||
36 | |||
37 | # Put virtual/db in any appropriate provider of a | ||
38 | # relational database, use it as a dependency in | ||
39 | # place of a specific db and use: | ||
40 | # | ||
41 | # PREFERRED_PROVIDER_virtual/db | ||
42 | # | ||
43 | # to select the correct db in the build (distro) .conf | ||
44 | PROVIDES += "${VIRTUAL_NAME}" | ||
45 | |||
46 | inherit autotools | ||
47 | |||
48 | # The executables go in a separate package - typically there | ||
49 | # is no need to install these unless doing real database | ||
50 | # management on the system. | ||
51 | inherit lib_package | ||
52 | |||
53 | PACKAGES =+ "${PN}-cxx" | ||
54 | FILES_${PN}-cxx = "${libdir}/*cxx*so" | ||
55 | |||
56 | # The dev package has the .so link (as in db3) and the .a's - | ||
57 | # it is therefore incompatible (cannot be installed at the | ||
58 | # same time) as the db3 package | ||
59 | # sort out the .so since they do version prior to the .so | ||
60 | SOLIBS = "-6*.so" | ||
61 | FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so" | ||
62 | |||
63 | #configuration - set in local.conf to override | ||
64 | # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix) | ||
65 | DB6_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql" | ||
66 | |||
67 | EXTRA_OECONF = "${DB6_CONFIG} --enable-shared --enable-cxx --with-sysroot" | ||
68 | |||
69 | # Cancel the site stuff - it's set for db3 and destroys the configure. | ||
70 | CONFIG_SITE = "" | ||
71 | |||
72 | AUTOTOOLS_SCRIPT_PATH = "${S}/dist" | ||
73 | |||
74 | do_configure() { | ||
75 | cd ${B} | ||
76 | gnu-configize --force ${AUTOTOOLS_SCRIPT_PATH} | ||
77 | oe_runconf | ||
78 | } | ||
79 | |||
80 | EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" | ||
81 | EXTRA_OEMAKE += "STRIP=true docdir=${docdir}/db/" | ||
82 | |||
83 | do_compile_prepend() { | ||
84 | # Stop libtool adding RPATHs | ||
85 | sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/libtool | ||
86 | } | ||
87 | |||
88 | do_install_append() { | ||
89 | mkdir -p ${D}/${includedir}/db60 | ||
90 | mv ${D}/${includedir}/db.h ${D}/${includedir}/db60/. | ||
91 | mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db60/. | ||
92 | ln -s db60/db.h ${D}/${includedir}/db.h | ||
93 | ln -s db60/db_cxx.h ${D}/${includedir}/db_cxx.h | ||
94 | |||
95 | # Prune the documentation to remove large (PDF) or pointless (Java) files. | ||
96 | find ${D}${docdir} -name *.pdf -delete | ||
97 | rm -rf ${D}${docdir}/db/java | ||
98 | rm -rf ${D}${docdir}/db/csharp | ||
99 | |||
100 | # The makefiles use cp -p, so we need to chmod until that is fixed. | ||
101 | chown -R root:root ${D} | ||
102 | } | ||
103 | |||
104 | # libdb isn't versioned in the typical manner (libdb-6.0.so is the full library | ||
105 | # name) so skip these checks. | ||
106 | INSANE_SKIP_${PN} = "dev-so" | ||
107 | INSANE_SKIP_${PN}-cxx = "dev-so" | ||
108 | |||
109 | BBCLASSEXTEND = "native nativesdk" | ||
110 | |||
111 | RECIPE_NO_UPDATE_REASON = "latest db does not work with RPM-5.x due to changes in locking semantics" | ||