summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_6.0.30.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-23 14:05:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-10 14:12:17 +0100
commit3a6f0b66a5550b392317c6ad77a4e8298906d218 (patch)
tree2b288a9061f6dd424c3365b111d0401ee9ad2df2 /meta/recipes-support/db/db_6.0.30.bb
parentb58c5dc787227aaf069f812450ff366608097099 (diff)
downloadpoky-3a6f0b66a5550b392317c6ad77a4e8298906d218.tar.gz
db: use S/B more idiomatically
Instead of setting S to a directory inside the tarball and B to another directory inside the tarball, use the default value of S and set AUTOTOOLS_SCRIPT_PATH to the right path to find configure. Update the patches so they still apply, and clean up the recipe slightly. Because something is not quite right regarding quilt and patching, add a PR bump to the recipes to ensure that a clean work directory is used: for some reason rebuilds will rarely fail to patch correctly. (From OE-Core rev: dcbef72b8344c22617d65ea1e9f0fa7ad9a742bd) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db/db_6.0.30.bb')
-rw-r--r--meta/recipes-support/db/db_6.0.30.bb53
1 files changed, 25 insertions, 28 deletions
diff --git a/meta/recipes-support/db/db_6.0.30.bb b/meta/recipes-support/db/db_6.0.30.bb
index 018dd58f67..08528206f9 100644
--- a/meta/recipes-support/db/db_6.0.30.bb
+++ b/meta/recipes-support/db/db_6.0.30.bb
@@ -15,13 +15,15 @@ LICENSE = "AGPL-3.0"
15VIRTUAL_NAME ?= "virtual/db" 15VIRTUAL_NAME ?= "virtual/db"
16RCONFLICTS_${PN} = "db3" 16RCONFLICTS_${PN} = "db3"
17 17
18PR = "r1"
19
18# Note, when upgraded to 6.1.x, a patch in RPM will need to be removed to activate db 6.1 support. 20# Note, when upgraded to 6.1.x, a patch in RPM will need to be removed to activate db 6.1 support.
19 21
20SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz" 22SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz \
21SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \ 23 file://arm-thumb-mutex_db5.patch \
22 file://fix-parallel-build.patch \ 24 file://fix-parallel-build.patch \
23 file://Makefile-let-libso_target-depend-on-bt_rec.patch \ 25 file://Makefile-let-libso_target-depend-on-bt_rec.patch \
24 file://Makefile-let-libdb-6.0.la-depend-os_map.l.patch;patchdir=.. \ 26 file://Makefile-let-libdb-6.0.la-depend-os_map.l.patch \
25 " 27 "
26 28
27SRC_URI[md5sum] = "ad28eb86ad3203b5422844db179c585b" 29SRC_URI[md5sum] = "ad28eb86ad3203b5422844db179c585b"
@@ -31,9 +33,7 @@ SRC_URI[sha256sum] = "608e4b1cf390e9bf54c0ef00c5bd9ca76d36e2261b9f4d33d54516f3f6
31UPSTREAM_CHECK_REGEX = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar" 33UPSTREAM_CHECK_REGEX = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar"
32UPSTREAM_CHECK_URI = "http://www.oracle.com/technetwork/products/berkeleydb/downloads/index-082944.html" 34UPSTREAM_CHECK_URI = "http://www.oracle.com/technetwork/products/berkeleydb/downloads/index-082944.html"
33 35
34LIC_FILES_CHKSUM = "file://../LICENSE;md5=1ec8b0b17cc31513fe35ab10716f8490" 36LIC_FILES_CHKSUM = "file://LICENSE;md5=1ec8b0b17cc31513fe35ab10716f8490"
35
36inherit autotools
37 37
38# Put virtual/db in any appropriate provider of a 38# Put virtual/db in any appropriate provider of a
39# relational database, use it as a dependency in 39# relational database, use it as a dependency in
@@ -44,13 +44,7 @@ inherit autotools
44# to select the correct db in the build (distro) .conf 44# to select the correct db in the build (distro) .conf
45PROVIDES += "${VIRTUAL_NAME}" 45PROVIDES += "${VIRTUAL_NAME}"
46 46
47# bitbake isn't quite clever enough to deal with sleepycat, 47inherit autotools
48# the distribution sits in the expected directory, but all
49# the builds must occur from a sub-directory. The following
50# persuades bitbake to go to the right place
51S = "${WORKDIR}/db-${PV}/dist"
52B = "${WORKDIR}/db-${PV}/build_unix"
53SPDX_S = "${WORKDIR}/db-${PV}"
54 48
55# The executables go in a separate package - typically there 49# The executables go in a separate package - typically there
56# is no need to install these unless doing real database 50# is no need to install these unless doing real database
@@ -60,7 +54,6 @@ inherit lib_package
60PACKAGES =+ "${PN}-cxx" 54PACKAGES =+ "${PN}-cxx"
61FILES_${PN}-cxx = "${libdir}/*cxx*so" 55FILES_${PN}-cxx = "${libdir}/*cxx*so"
62 56
63
64# The dev package has the .so link (as in db3) and the .a's - 57# The dev package has the .so link (as in db3) and the .a's -
65# it is therefore incompatible (cannot be installed at the 58# it is therefore incompatible (cannot be installed at the
66# same time) as the db3 package 59# same time) as the db3 package
@@ -74,6 +67,17 @@ DB6_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disabl
74 67
75EXTRA_OECONF = "${DB6_CONFIG} --enable-shared --enable-cxx --with-sysroot" 68EXTRA_OECONF = "${DB6_CONFIG} --enable-shared --enable-cxx --with-sysroot"
76 69
70# Cancel the site stuff - it's set for db3 and destroys the configure.
71CONFIG_SITE = ""
72
73AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
74
75do_configure() {
76 cd ${B}
77 gnu-configize --force ${AUTOTOOLS_SCRIPT_PATH}
78 oe_runconf
79}
80
77# Override the MUTEX setting here, the POSIX library is 81# Override the MUTEX setting here, the POSIX library is
78# the default - "POSIX/pthreads/library". 82# the default - "POSIX/pthreads/library".
79# Don't ignore the nice SWP instruction on the ARM: 83# Don't ignore the nice SWP instruction on the ARM:
@@ -83,20 +87,11 @@ MUTEX = ""
83MUTEX_arm = "${ARM_MUTEX}" 87MUTEX_arm = "${ARM_MUTEX}"
84MUTEX_armeb = "${ARM_MUTEX}" 88MUTEX_armeb = "${ARM_MUTEX}"
85EXTRA_OECONF += "${MUTEX}" 89EXTRA_OECONF += "${MUTEX}"
86EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" 90EXTRA_OEMAKE += "STRIP=true"
87
88# Cancel the site stuff - it's set for db3 and destroys the
89# configure.
90CONFIG_SITE = ""
91do_configure() {
92 gnu-configize --force ${S}
93 export STRIP="true"
94 oe_runconf
95}
96 91
97do_compile_prepend() { 92do_compile_prepend() {
98 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' \ 93 # Stop libtool adding RPATHs
99 ${B}/libtool 94 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/libtool
100} 95}
101 96
102do_install_append() { 97do_install_append() {
@@ -117,6 +112,8 @@ do_install_append() {
117 chown -R root:root ${D} 112 chown -R root:root ${D}
118} 113}
119 114
115# libdb isn't versioned in the typical manner (libdb-6.0.so is the full library
116# name) so skip these checks.
120INSANE_SKIP_${PN} = "dev-so" 117INSANE_SKIP_${PN} = "dev-so"
121INSANE_SKIP_${PN}-cxx = "dev-so" 118INSANE_SKIP_${PN}-cxx = "dev-so"
122 119