diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-04-18 15:53:10 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-04-30 14:37:37 +0100 |
commit | f23e0a1b0a52c4e367182854a8eb7de1dcd73560 (patch) | |
tree | 77de7b1e064f0426656794d6bae48db7322f4bb9 /meta/recipes-support/ca-certificates/ca-certificates_20210119.bb | |
parent | 71818465cbcea421a5ebd90ef7a76387d5a45802 (diff) | |
download | poky-f23e0a1b0a52c4e367182854a8eb7de1dcd73560.tar.gz |
ca-certificates: Fix openssl runtime cert dependencies
With commit dc778c70449ee5401b5a24ad18b22b88338c47c5, dependency was
moved to openssl-bin which in itself was a fine change, but dropping
dependency on openssl too should have been kept along, dropping this
meant that openssl binary wont be able to validate secure connections as
the CApath files wont be installed, which infact are required for
openssl bins to work, following call e.g. fails
$ openssl s_client -connect google.com:443
....
New, TLSv1.3, Cipher is TLS_AES_256_GCM_SHA384
Server public key is 256 bit
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
Early data was not sent
Verify return code: 20 (unable to get local issuer certificate)
....
The local issuer certs are not found in default location
/usr/lib/ssh-1.1/certs, this dir and its content is installed by openssl package
therefore re-add the dependency on openssl
(From OE-Core rev: ba2774dc6ba119094861c0723858e4b47e9b7eed)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit eaf377315efc73d6ffe361372a873918b3bb3bf5)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ca-certificates/ca-certificates_20210119.bb')
-rw-r--r-- | meta/recipes-support/ca-certificates/ca-certificates_20210119.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20210119.bb b/meta/recipes-support/ca-certificates/ca-certificates_20210119.bb index 888a235c1a..7dcc86fdc1 100644 --- a/meta/recipes-support/ca-certificates/ca-certificates_20210119.bb +++ b/meta/recipes-support/ca-certificates/ca-certificates_20210119.bb | |||
@@ -83,8 +83,8 @@ do_install_append_class-native () { | |||
83 | SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates | 83 | SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates |
84 | } | 84 | } |
85 | 85 | ||
86 | RDEPENDS_${PN}_class-target = "openssl-bin" | 86 | RDEPENDS_${PN}_append_class-target = " openssl-bin openssl" |
87 | RDEPENDS_${PN}_class-native = "openssl-native" | 87 | RDEPENDS_${PN}_append_class-native = " openssl-native" |
88 | RDEPENDS_${PN}_class-nativesdk = "nativesdk-openssl-bin" | 88 | RDEPENDS_${PN}_append_class-nativesdk = " nativesdk-openssl-bin nativesdk-openssl" |
89 | 89 | ||
90 | BBCLASSEXTEND = "native nativesdk" | 90 | BBCLASSEXTEND = "native nativesdk" |