summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.61.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:14:44 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-04 14:13:33 +0100
commitf6f7db7c2ab409abab0e7a2f9d36a35419e76076 (patch)
tree970cf2a7171966aeddaa9af5d563090bcdac6e2e /meta/recipes-support/boost/bjam-native_1.61.0.bb
parent7a0ef75f3e0455174a94b8b1a5b61f41cd2b92ba (diff)
downloadpoky-f6f7db7c2ab409abab0e7a2f9d36a35419e76076.tar.gz
boost: update to 1.61.0
0001-Do-not-qualify-fenv.h-names-that-might-be-macros.patch has been merged upstream. (From OE-Core rev: 25d4129bab9f6abeecbfec6b69612e387851bfe3) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.61.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.61.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.61.0.bb b/meta/recipes-support/boost/bjam-native_1.61.0.bb
new file mode 100644
index 0000000000..32646d707b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.61.0.bb
@@ -0,0 +1,18 @@
1include boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://bjam-native-build-bjam.debug.patch"
9
10do_compile() {
11 ./bootstrap.sh --with-toolset=gcc
12}
13
14do_install() {
15 install -d ${D}${bindir}/
16 # install unstripped version for bjam
17 install -c -m 755 bjam.debug ${D}${bindir}/bjam
18}