summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2017-09-06 15:08:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 17:30:29 +0100
commit1db8c61b5b937fb6d6fe7980ea471f800a21340a (patch)
treeac72ac991175470e0065e477369f414c0f3da880 /meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
parent4efeceb8a672dd9372820daa143903a934e4d20a (diff)
downloadpoky-1db8c61b5b937fb6d6fe7980ea471f800a21340a.tar.gz
bmap-tools: upgrade to v3.4
Upgraded to the latest upstream release. (From OE-Core rev: fa36678698108023242f2afbd4e54d6709f84420) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bmap-tools/bmap-tools_3.4.bb')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_3.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
new file mode 100644
index 0000000000..3f75fad44b
--- /dev/null
+++ b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "git://github.com/01org/bmap-tools.git"
13SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS_${PN} = "python-core python-compression python-mmap"
18
19inherit setuptools
20
21BBCLASSEXTEND = "native"
22
23do_install_append_class-native() {
24 sed -i -e 's|^#!.*/usr/bin/python-native/python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
25}