summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-08-29 17:30:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-03 09:58:38 +0100
commitbd02a3851c95ebdfcf2d3c672fab15a3be1df08e (patch)
tree03c4538fc9a74179c2df2fa9d254ec4d6b470a0c /meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
parent32ac9347d66e0df4d59c1e211aca5e2909ecb937 (diff)
downloadpoky-bd02a3851c95ebdfcf2d3c672fab15a3be1df08e.tar.gz
bdwgc: update to 7.6.0
Remove backported NIOS2 patch. README.QUICK checksum updated; the license part of the file is unchaged. (From OE-Core rev: ee16cc4ad552502212055af46b3e97a312a13e69) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bdwgc/bdwgc_7.6.0.bb')
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.6.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
new file mode 100644
index 0000000000..55ea452068
--- /dev/null
+++ b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=4f81f24ec69726c312487c2ac740e9e3"
23
24SRCREV = "8ac1d84a40eb7a431fec1b8097e3f24b48fb23fa"
25SRC_URI = "git://github.com/ivmai/bdwgc.git \
26 file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \
27 "
28
29FILES_${PN}-doc = "${datadir}"
30
31S = "${WORKDIR}/git"
32
33ARM_INSTRUCTION_SET = "arm"
34
35inherit autotools pkgconfig
36
37# by default use external libatomic-ops
38PACKAGECONFIG ??= "libatomic-ops"
39PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
40
41BBCLASSEXTEND = "native nativesdk"