summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bdwgc/bdwgc_7.2d.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-06-04 09:52:20 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-07 16:48:24 +0100
commitcf2c4b046fc9b4d98b9846434e44f6a9afd5061b (patch)
treee5e01d4146d3d4153d969882e2d55aef3ac76596 /meta/recipes-support/bdwgc/bdwgc_7.2d.bb
parent2ee07173a6885328de68d1e0a09b5cf95c8d273e (diff)
downloadpoky-cf2c4b046fc9b4d98b9846434e44f6a9afd5061b.tar.gz
bdwgc: enable full version name in recipe name
bdwgc has version names that may or may not contain a revision (for example 7.2d or simply 7.2). The current recipe specifies the revision as a separate variable, which confuses the automatic version checker. This patch enables using the full version name as part of the recipe name. (From OE-Core rev: 662b485e155257695ac7cc47f4cd26ddf94720ba) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bdwgc/bdwgc_7.2d.bb')
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.2d.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.2d.bb b/meta/recipes-support/bdwgc/bdwgc_7.2d.bb
new file mode 100644
index 0000000000..46e5257671
--- /dev/null
+++ b/meta/recipes-support/bdwgc/bdwgc_7.2d.bb
@@ -0,0 +1,38 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
20SECTION = "devel"
21LICENSE = "MIT & FSF-Unlimited & GPL-2.0"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=9b9dd874f6940641b6ab19893ee8f1cc \
23 file://doc/README;md5=92e7dd0334d1f672b699cd0aca08bef0 \
24 file://libatomic_ops/doc/LICENSING.txt;md5=607073e04548eac7d1f763e480477bab"
25
26SRC_URI = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV}.tar.gz"
27
28SRC_URI[md5sum] = "91340b28c61753a789eb6077675d87d2"
29SRC_URI[sha256sum] = "d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e"
30FILES_${PN}-doc = "/usr/share"
31
32REAL_PV = "${@[d.getVar('PV',1)[:-1], d.getVar('PV',1)][(d.getVar('PV',1)[-1]).isdigit()]}"
33S = "${WORKDIR}/gc-${REAL_PV}"
34
35ARM_INSTRUCTION_SET = "arm"
36
37inherit autotools
38BBCLASSEXTEND = "native nativesdk"