summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.4.2.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-12-17 10:00:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:57 +0000
commitaa360877348aa325ff9dcd8fd70e502deacffb39 (patch)
treec28c30b710616064d5479f582f32a0f081355672 /meta/recipes-support/apr/apr_1.4.2.bb
parent552169e89aea5706100a67f1f1e68a85600e1105 (diff)
downloadpoky-aa360877348aa325ff9dcd8fd70e502deacffb39.tar.gz
apr: Update to 1.4.2
Add buildconf_fix.patch of removing new libtool detection method to avoid config failure. Handled build/libtool.m4 & apr_rules.mk after configure to take place of "top_builddir" by "apr_builddir", as these files would be reused by apr-util. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-support/apr/apr_1.4.2.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.4.2.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.2.bb b/meta/recipes-support/apr/apr_1.4.2.bb
new file mode 100644
index 0000000000..fe983eb7f7
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.4.2.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "Apache Portable Runtime (APR) library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4
5LICENSE = "Apache License, Version 2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b \
7 file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
8
9PR = "r0"
10
11SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
12 file://configure_fixes.patch;patch=1 \
13 file://cleanup.patch;patch=1 \
14 file://configfix.patch;patch=1 \
15 file://buildconf_fix.patch;patch=1"
16
17SRC_URI[md5sum] = "4b00e8f70c067893d075577962656b35"
18SRC_URI[sha256sum] = "2017ca700694d09d2b0b21dd7c4d195e43a48735aac88526160c6195ee8f5391"
19
20inherit autotools lib_package binconfig
21
22OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
23
24do_configure_prepend() {
25 cd ${S}
26 ./buildconf
27}
28
29#for some reason, build/libtool.m4 handled by buildconf still be overwritten
30#when autoconf, so handle it again.
31do_configure_append() {
32 cd ${S}
33 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/libtool.m4
34 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/apr_rules.mk
35}
36
37SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
38
39apr_sysroot_preprocess () {
40 d=${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/apr
41 install -d $d/
42 cp ${S}/build/apr_rules.mk $d/
43 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
44 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
45 sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g $d/apr_rules.mk
46 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
47 cp ${S}/build/mkdir.sh $d/
48 cp ${S}/build/make_exports.awk $d/
49 cp ${S}/build/make_var_export.awk $d/
50}