summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.3.3.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-12-17 10:00:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:57 +0000
commitaa360877348aa325ff9dcd8fd70e502deacffb39 (patch)
treec28c30b710616064d5479f582f32a0f081355672 /meta/recipes-support/apr/apr_1.3.3.bb
parent552169e89aea5706100a67f1f1e68a85600e1105 (diff)
downloadpoky-aa360877348aa325ff9dcd8fd70e502deacffb39.tar.gz
apr: Update to 1.4.2
Add buildconf_fix.patch of removing new libtool detection method to avoid config failure. Handled build/libtool.m4 & apr_rules.mk after configure to take place of "top_builddir" by "apr_builddir", as these files would be reused by apr-util. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-support/apr/apr_1.3.3.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.3.3.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta/recipes-support/apr/apr_1.3.3.bb b/meta/recipes-support/apr/apr_1.3.3.bb
deleted file mode 100644
index 26cc01fe7a..0000000000
--- a/meta/recipes-support/apr/apr_1.3.3.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Apache Portable Runtime (APR) library"
2SECTION = "libs"
3LICENSE = "Apache License, Version 2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b"
5PR = "r5"
6
7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
8 file://configure_fixes.patch;patch=1 \
9 file://cleanup.patch;patch=1 \
10 file://configfix.patch;patch=1"
11
12SRC_URI[md5sum] = "2090c21dee4f0eb1512604127dcd158f"
13SRC_URI[sha256sum] = "d95f3b78366c86317043304864bb08cb836312c87ea7d142a4c02154e7e0dd37"
14
15inherit autotools lib_package binconfig
16
17OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
18
19do_configure_prepend() {
20 cd ${S}
21 ./buildconf
22}
23
24SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
25
26apr_sysroot_preprocess () {
27 d=${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/apr
28 install -d $d/
29 cp ${S}/build/apr_rules.mk $d/
30 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
31 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
32 sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g $d/apr_rules.mk
33 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
34 cp ${S}/build/mkdir.sh $d/
35 cp ${S}/build/make_exports.awk $d/
36 cp ${S}/build/make_var_export.awk $d/
37}