diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-01-12 18:55:19 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-16 23:08:26 +0000 |
commit | 9d4cad3a6b91ed744f2648f60a2d516aae4cc0f3 (patch) | |
tree | 44e1b95a4e19b995d6a79ad9ebf8d0c349cdd1f5 /meta/recipes-support/apr/apr-util_1.5.4.bb | |
parent | 646230a4de1bf9bd6726dcf6d86fd6e1b6081c6a (diff) | |
download | poky-9d4cad3a6b91ed744f2648f60a2d516aae4cc0f3.tar.gz |
apr-util: fix B != S
And bump PR to avoid:
x86_64-linux-libtool: error: 'dbm/apr_dbm_gdbm.la' is not a valid libtool archive
(From OE-Core rev: e712a31287eb830f365df456e68bc95bdacb1a4a)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.5.4.bb')
-rw-r--r-- | meta/recipes-support/apr/apr-util_1.5.4.bb | 17 |
1 files changed, 10 insertions, 7 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.4.bb b/meta/recipes-support/apr/apr-util_1.5.4.bb index 1cd47b1468..ac01b63ecd 100644 --- a/meta/recipes-support/apr/apr-util_1.5.4.bb +++ b/meta/recipes-support/apr/apr-util_1.5.4.bb | |||
@@ -28,22 +28,25 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ | |||
28 | --with-expat=${STAGING_DIR_HOST}${prefix}" | 28 | --with-expat=${STAGING_DIR_HOST}${prefix}" |
29 | 29 | ||
30 | 30 | ||
31 | inherit autotools-brokensep lib_package binconfig | 31 | inherit autotools lib_package binconfig |
32 | |||
33 | PR = "r1" | ||
32 | 34 | ||
33 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" | 35 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" |
34 | 36 | ||
35 | do_configure_append() { | 37 | do_configure_append() { |
36 | if [ "${CLASSOVERRIDE}" = "class-target" ]; then | 38 | if [ "${CLASSOVERRIDE}" = "class-target" ]; then |
37 | cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk | 39 | cp ${STAGING_DATADIR}/apr/apr_rules.mk ${B}/build/rules.mk |
38 | fi | 40 | fi |
39 | } | 41 | } |
40 | do_configure_prepend_class-native() { | 42 | do_configure_prepend_class-native() { |
41 | cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk | 43 | mkdir ${B}/build |
44 | cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${B}/build/rules.mk | ||
42 | } | 45 | } |
43 | do_configure_append_class-native() { | 46 | do_configure_append_class-native() { |
44 | sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk | 47 | sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk |
45 | # sometimes there isn't SHELL | 48 | # sometimes there isn't SHELL |
46 | sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk | 49 | sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk |
47 | } | 50 | } |
48 | 51 | ||
49 | FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so" | 52 | FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so" |
@@ -54,7 +57,7 @@ FILES_${PN}-staticdev += "${libdir}/apr-util-1/apr_dbm_gdbm.a" | |||
54 | inherit ptest | 57 | inherit ptest |
55 | 58 | ||
56 | do_compile_ptest() { | 59 | do_compile_ptest() { |
57 | cd ${S}/test | 60 | cd ${B}/test |
58 | oe_runmake | 61 | oe_runmake |
59 | } | 62 | } |
60 | 63 | ||
@@ -62,6 +65,6 @@ do_install_ptest() { | |||
62 | t=${D}${PTEST_PATH}/test | 65 | t=${D}${PTEST_PATH}/test |
63 | mkdir $t | 66 | mkdir $t |
64 | for i in testall data; do \ | 67 | for i in testall data; do \ |
65 | cp -r ${S}/test/$i $t; \ | 68 | cp -r ${B}/test/$i $t; \ |
66 | done | 69 | done |
67 | } | 70 | } |