diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2015-09-10 21:18:07 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-09-14 20:46:39 +0100 |
commit | 572e50d73a1ddf97ec5e81fb114bbb5c730cae2e (patch) | |
tree | 2bc6cd350ab9b9e055d879366ef74911a1aa40e2 /meta/recipes-sato/webkit/webkitgtk_2.8.5.bb | |
parent | 7eabed3039b28119bb6642205bf26460695cb22e (diff) | |
download | poky-572e50d73a1ddf97ec5e81fb114bbb5c730cae2e.tar.gz |
webkitgtk: add a new recipe for latest upstream version
Also, add a backported patch that prevents too long command lines from
happening.
Recipe for the obsolete webkit-gtk 1.8.3 is removed in a separate commit.
(From OE-Core rev: a7f06b7821f788f77ae5e0f2822480f85e338ad1)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.8.5.bb')
-rw-r--r-- | meta/recipes-sato/webkit/webkitgtk_2.8.5.bb | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb new file mode 100644 index 0000000000..365f20bbb8 --- /dev/null +++ b/meta/recipes-sato/webkit/webkitgtk_2.8.5.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | SUMMARY = "WebKit web rendering engine for the GTK+ platform" | ||
2 | HOMEPAGE = "http://www.webkitgtk.org/" | ||
3 | BUGTRACKER = "http://bugs.webkit.org/" | ||
4 | |||
5 | LICENSE = "BSD & LGPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \ | ||
7 | file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \ | ||
8 | file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \ | ||
9 | file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \ | ||
10 | file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \ | ||
11 | " | ||
12 | |||
13 | SRC_URI = "\ | ||
14 | http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \ | ||
15 | file://0001-This-patch-fixes-a-command-line-that-is-too-long-ove.patch \ | ||
16 | " | ||
17 | SRC_URI[md5sum] = "df79991848a5096d3a75289ebce547ae" | ||
18 | SRC_URI[sha256sum] = "3d1f0c534935f43fd74df90f2648fcee672d60f1f57a30fa557a77891ae04d20" | ||
19 | |||
20 | inherit cmake lib_package pkgconfig perlnative pythonnative | ||
21 | |||
22 | DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \ | ||
23 | gtk+ gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \ | ||
24 | pango icu bison-native gnome-common gawk intltool-native libwebp \ | ||
25 | atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \ | ||
26 | ruby-native libsecret libnotify gstreamer1.0-plugins-bad \ | ||
27 | " | ||
28 | DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}" | ||
29 | |||
30 | EXTRA_OECMAKE = " \ | ||
31 | -DPORT=GTK \ | ||
32 | -DCMAKE_BUILD_TYPE=Release \ | ||
33 | -DENABLE_INTROSPECTION=False \ | ||
34 | -DENABLE_MINIBROWSER=True \ | ||
35 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '-DENABLE_WEBGL=True', '-DENABLE_WEBGL=False', d)} \ | ||
36 | " | ||
37 | |||
38 | # Javascript JIT is not supported on powerpc | ||
39 | EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=False " | ||
40 | EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=False " | ||
41 | |||
42 | # ARM JIT code does not build on ARMv5/6 anymore, apparently they test only on v7 onwards | ||
43 | EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=False " | ||
44 | EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=False " | ||
45 | |||
46 | # binutils 2.25.1 has a bug on aarch64: | ||
47 | # https://sourceware.org/bugzilla/show_bug.cgi?id=18430 | ||
48 | EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=False " | ||
49 | |||
50 | # JIT not supported on MIPS either | ||
51 | EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=False " | ||
52 | EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=False " | ||
53 | |||
54 | FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so" | ||
55 | FILES_${PN}-dbg += "${libdir}/webkit2gtk-4.0/injected-bundle/.debug/libwebkit2gtkinjectedbundle.so" | ||
56 | FILES_${PN}-dbg += "${libdir}/webkitgtk/webkit2gtk-4.0/.debug/*" | ||
57 | |||