summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.32.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-05-05 17:18:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-09 23:30:15 +0100
commit99445990caa21c7ad076fc086eb8a759f2a69aae (patch)
tree8a40b0c338dc6e2e6ad6ee9046c47cb289f2593a /meta/recipes-sato/webkit/webkitgtk_2.32.0.bb
parent39932f22fa0710897c82e807e699beaf985b419a (diff)
downloadpoky-99445990caa21c7ad076fc086eb8a759f2a69aae.tar.gz
webkitgtk: update 2.30.6 -> 2.32.0
Drop 0001-Extend-atomics-check-to-include-1-byte-CAS-test.patch (merged upstream). Rebase other patches. (From OE-Core rev: f64e9ba5f0d48e34d7022bf74bd9765f9e8a792c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.32.0.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.32.0.bb152
1 files changed, 152 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.32.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.32.0.bb
new file mode 100644
index 0000000000..8a07fadd9b
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.32.0.bb
@@ -0,0 +1,152 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
18 file://0001-Fix-build-with-musl.patch \
19 file://include_xutil.patch \
20 file://reduce-memory-overheads.patch \
21 file://musl-lower-stack-usage.patch \
22 file://0001-MiniBrowser-Fix-reproduciblity.patch \
23 file://49a19c49c6de8af74e521f36cb43e6c1ec2e391c.patch \
24 "
25
26SRC_URI[sha256sum] = "9d7df4dae9ada2394257565acc2a68ace9308c4c61c3fcc00111dc1f11076bf0"
27
28inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
29
30ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
31REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
32
33CVE_PRODUCT = "webkitgtk webkitgtk\+"
34
35DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
36 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
37 pango icu bison-native gawk intltool-native libwebp \
38 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
39 ruby-native libnotify gstreamer1.0-plugins-bad \
40 gettext-native glib-2.0 glib-2.0-native libtasn1 \
41 "
42
43PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
46 enchant \
47 libsecret \
48 "
49
50PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
51PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
52PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
53PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
54PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
55PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
56PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
57PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
58PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
59PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
60PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
61PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
62PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
63
64# webkitgtk is full of /usr/bin/env python, particular for generating docs
65do_configure[postfuncs] += "setup_python_link"
66setup_python_link() {
67 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
68 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
69 fi
70}
71
72EXTRA_OECMAKE = " \
73 -DPORT=GTK \
74 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
75 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
76 -DENABLE_MINIBROWSER=ON \
77 -DPYTHON_EXECUTABLE=`which python3` \
78 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
79 -DENABLE_GAMEPAD=OFF \
80 "
81
82# Javascript JIT is not supported on ARC
83EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
84# By default 25-bit "medium" calls are used on ARC
85# which is not enough for binaries larger than 32 MiB
86CFLAGS_append_arc = " -mlong-calls"
87CXXFLAGS_append_arc = " -mlong-calls"
88
89# Javascript JIT is not supported on powerpc
90EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
91EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
92
93# ARM JIT code does not build on ARMv4/5/6 anymore
94EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
95EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
96EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
97
98EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
99EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
100
101# JIT and gold linker does not work on RISCV
102EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
103EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
104
105# JIT not supported on MIPS either
106EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
107
108# JIT not supported on X32
109# An attempt was made to upstream JIT support for x32 in
110# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
111# unresolved due to limited X32 adoption.
112EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
113
114SECURITY_CFLAGS_remove_aarch64 = "-fpie"
115SECURITY_CFLAGS_append_aarch64 = " -fPIE"
116
117FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
118
119RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
120
121# http://errors.yoctoproject.org/Errors/Details/20370/
122ARM_INSTRUCTION_SET_armv4 = "arm"
123ARM_INSTRUCTION_SET_armv5 = "arm"
124ARM_INSTRUCTION_SET_armv6 = "arm"
125
126# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
127# https://bugs.webkit.org/show_bug.cgi?id=159880
128# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
129# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
130ARM_INSTRUCTION_SET_armv7a = "thumb"
131ARM_INSTRUCTION_SET_armv7r = "thumb"
132ARM_INSTRUCTION_SET_armv7ve = "thumb"
133
134# introspection inside qemu-arm hangs forever on musl/arm builds
135# therefore disable GI_DATA
136GI_DATA_ENABLED_libc-musl_armv7a = "False"
137GI_DATA_ENABLED_libc-musl_armv7ve = "False"
138
139# Can't be built with ccache
140CCACHE_DISABLE = "1"
141
142PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
143src_package_preprocess () {
144 # Trim build paths from comments in generated sources to ensure reproducibility
145 sed -i -e "s,${WORKDIR},,g" \
146 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
147 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
148 ${B}/DerivedSources/JavaScriptCore/*.h \
149 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
150 ${B}/DerivedSources/MiniBrowser/*.c
151}
152